Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 30

Thread: Two wireless card, how do I disable one of them?

  1. #11
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,574
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: Two wireless card, how do I disable one of them?

    Let's try the updated driver suite compat-wireless. Please get a temporary ethernet connection and do:
    Code:
    sudo apt-get install linux-backports-modules-cw-3.6-xxx-generic
    For the xxx, substitute your Ubuntu version here:
    Code:
    lsb_release -a
    For example, on my machine, I get:
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 12.10
    Release: 12.10
    Codename: quantal
    So I would need linux-backports-modules-cw-3.6-quantal-generic. If you have quantal or precise, please proceed. If some other version, post back and we'll help.

    Reboot. Does it connect? If not, try again:
    Code:
    sudo modprobe -r rtl8192cu
    sudo modprobe rtl8192cu swenc=1
    Now does it connect?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  2. #12
    Join Date
    Feb 2008
    Location
    Massachusetts
    Beans
    58
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Two wireless card, how do I disable one of them?

    Unfortunately after I updated the modules (I am running precise) the behavior is unchanged. Multiple reboots and the modprobe commands did not alter the outcome. If this is any help, this is the behavior that made me decide the original laptop Intel Pci card was bad (it would find the correct SSID, but could never connect). When I installed the USB wireless on widows boot that solved the problem. When I started this thread I thought that it was the presence of both cards that caused the wireless failure on boot to the LUBUNTU partition. But in reality it is the Realtek USB wireless that is now recognizing the correct SSID but unable to connect.

  3. #13
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,574
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: Two wireless card, how do I disable one of them?

    Quote Originally Posted by Herber View Post
    Unfortunately after I updated the modules (I am running precise) the behavior is unchanged. Multiple reboots and the modprobe commands did not alter the outcome. If this is any help, this is the behavior that made me decide the original laptop Intel Pci card was bad (it would find the correct SSID, but could never connect). When I installed the USB wireless on widows boot that solved the problem. When I started this thread I thought that it was the presence of both cards that caused the wireless failure on boot to the LUBUNTU partition. But in reality it is the Realtek USB wireless that is now recognizing the correct SSID but unable to connect.
    May I see:
    Code:
    nm-tool
    Does the internal work in Windows?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  4. #14
    Join Date
    Feb 2008
    Location
    Massachusetts
    Beans
    58
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Two wireless card, how do I disable one of them?

    The internal wireless does not even recognize any wireless access points in windows anymore (just checked). The Realtek USB still works in windows, in Lubuntu it recognizes my home network and cycles through several attempts at connecting prior to (for lack of a better description) "giving up" and then it shows in the network manager GUI as "disconnected".

    The output you asked about:
    b@b-VGN-S360:~$ sudo nm-tool
    [sudo] password for b:

    NetworkManager Tool

    State: connected (global)

    - Device: wlan0 ----------------------------------------------------------------
    Type: 802.11 WiFi
    Driver: rtl8192cu
    State: disconnected
    Default: no
    HW Address: 80:1F:02:9B:EA:E8

    Capabilities:

    Wireless Properties
    WEP Encryption: yes
    WPA Encryption: yes
    WPA2 Encryption: yes

    Wireless Access Points


    - Device: eth0 [Wired connection 1] -------------------------------------------
    Type: Wired
    Driver: e100
    State: connected
    Default: yes
    HW Address: 08:00:46:F4:7C:A5

    Capabilities:
    Carrier Detect: yes
    Speed: 100 Mb/s

    Wired Properties
    Carrier: on

    IPv4 Settings:
    Address: 192.168.1.144
    Prefix: 24 (255.255.255.0)
    Gateway: 192.168.1.1

    DNS: 208.67.222.222
    DNS: 208.67.220.220
    DNS: 75.75.75.75


    b@b-VGN-S360:~$

  5. #15
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,574
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: Two wireless card, how do I disable one of them?

    I hate to say this in public, but Realtek (rtl) drivers are in flux right now. I understand that there are quite a few (20+) bug fixes in the pipeline. That doesn't help us today. Since you are running 12.04, there is a pretty good chance we could compile the driver from Realtek. You could also give the device to some Windows friend and get another anything-but-Realtek device. I assume you could also keep the ethernet connected.

    You might also download and try the 13.04 DVD to see if you connect as expected. If so, I'd install it.

    Which do you prefer?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  6. #16
    Join Date
    Feb 2008
    Location
    Massachusetts
    Beans
    58
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Two wireless card, how do I disable one of them?

    I really do appreciate all the time and effort you have given my problem here. I would try the 13.04 beta, but my machine is a "non-pae" machine and the kernel in use is apparently incompatible (that is why I am running LUBUNTU). I have a CD from the manufacturer with a linux driver on it, but I am suspicious that driver is the same one I am using currently (it is named rtl8192cu ver. 2.0.939.20200726.tar.gz). I think when you say compile the realtek you mean something to do with NDSWRAPPER and the windows driver? I would try that if you thought it might be useful. I think there may be a tutorial on the ubuntu site isn't there?

    And again thank you so much for your help here!!

  7. #17
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,574
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: Two wireless card, how do I disable one of them?

    I think when you say compile the realtek you mean something to do with NDSWRAPPER
    Not quite. I mean build the Realtek provided one-size-fits-all driver against your currently running kernel. Since you have the driver on the CD, we can explore that path easily. Please drag and drop rtl8192cu ver. 2.0.939.20200726.tar.gz from the CD to your desktop. Right click it and select 'Extract Here.' Look inside the resulting folder and see if anything, a README perhaps or a changelog, suggests when this was created. I doubt it is July 26, 2020. If it is relatively recent, 2011 or so, we can try to compile it. In anticipation of that, install the prerequisites:
    Code:
    sudo apt-get install linux-headers-generic build-essential
    Let me know what you find in the driver file.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  8. #18
    Join Date
    Feb 2008
    Location
    Massachusetts
    Beans
    58
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Two wireless card, how do I disable one of them?

    Other than the build information I don't see a date for the driver release, and a quick internet search didn't reveal a date either. I have extracted the .tar.gz and I have installed the build-essential.

  9. #19
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,574
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: Two wireless card, how do I disable one of them?

    Quote Originally Posted by Herber View Post
    Other than the build information I don't see a date for the driver release, and a quick internet search didn't reveal a date either. I have extracted the .tar.gz and I have installed the build-essential.
    When you open the folder in the file browser Nautilus (it may be something else in Lubuntu), what does the 'date modified' say? Here is an example.
    Attached Images Attached Images
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  10. #20
    Join Date
    Feb 2008
    Location
    Massachusetts
    Beans
    58
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Two wireless card, how do I disable one of them?

    7/27/2010 is the date on the .tar.gz on the CD.

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •