Results 1 to 7 of 7

Thread: The following packages have unmet dependencies

  1. #1
    Join Date
    Apr 2013
    Beans
    7

    The following packages have unmet dependencies

    Hello guys
    I have a problem in one of my packages, when i want to repair it in ubuntu software centre it shows:

    installArchives() failed: (Reading database ...
    dpkg: warning: files list file for package 'pri.ter-driver-pnm2ppa' missing; assuming package has no files currently installed
    (Reading database ... 5%
    (Reading database ... 10%
    (Reading database ... 15%
    (Reading database ... 20%
    (Reading database ... 25%
    (Reading database ... 30%
    (Reading database ... 35%
    (Reading database ... 40%
    (Reading database ... 45%
    (Reading database ... 50%
    (Reading database ... 55%
    (Reading database ... 60%
    (Reading database ... 65%
    (Reading database ... 70%
    (Reading database ... 75%
    (Reading database ... 80%
    (Reading database ... 85%
    (Reading database ... 90%
    (Reading database ... 95%
    (Reading database ... 100%
    (Reading database ... 182466 files and directories currently installed.)
    Unpacking openjdk-7-jre-lib (from .../openjdk-7-jre-lib_7u15-2.3.7-0ubuntu1~12.10.1_all.deb) ...
    dpkg-deb (subprocess): decompressing archive member: internal gzip read error: '<fd:4>: invalid literal/lengths set'
    dpkg-deb: error: subprocess <decompress> returned error exit status 2
    dpkg: error processing /var/cache/apt/archives/openjdk-7-jre-lib_7u15-2.3.7-0ubuntu1~12.10.1_all.deb (--unpack):
    cannot copy extracted data for './usr/lib/jvm/java-7-openjdk-common/jre/lib/ext/localedata.jar' to '/usr/lib/jvm/java-7-openjdk-common/jre/lib/ext/localedata.jar.dpkg-new': unexpected end of file or stream
    No apport report written because MaxReports is reached already
    Errors were encountered while processing:
    /var/cache/apt/archives/openjdk-7-jre-lib_7u15-2.3.7-0ubuntu1~12.10.1_all.deb
    Error in function:
    dpkg: dependency problems prevent configuration of openjdk-7-jre-headless:i386:
    openjdk-7-jre-headless:i386 depends on openjdk-7-jre-lib (= 7u15-2.3.7-0ubuntu1~12.10.1); however:
    Package openjdk-7-jre-lib is not installed.

    dpkg: error processing openjdk-7-jre-headless:i386 (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of ca-certificates-java:
    ca-certificates-java depends on openjdk-7-jre-headless (>= 7~u3-2.1.1~pre1-1) | java6-runtime-headless; however:
    Package openjdk-7-jre-headless:i386 is not configured yet.
    Package java6-runtime-headless is not installed.
    Package openjdk-7-jre-headless:i386 which provides java6-runtime-headless is not configured yet.

    dpkg: error processing ca-certificates-java (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of openjdk-7-jre:i386:
    openjdk-7-jre:i386 depends on openjdk-7-jre-headless (= 7u15-2.3.7-0ubuntu1~12.10.1); however:
    Package openjdk-7-jre-headless:i386 is not configured yet.

    dpkg: error processing openjdk-7-jre:i386 (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of icedtea-7-jre-jamvm:i386:
    icedtea-7-jre-jamvm:i386 depends on openjdk-7-jre-headless (= 7u15-2.3.7-0ubuntu1~12.10.1); however:
    Package openjdk-7-jre-headless:i386 is not configured yet.

    dpkg: error processing icedtea-7-jre-jamvm:i386 (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libatk-wrapper-java-jni:i386:
    libatk-wrapper-java-jni:i386 depends on default-jre | java2-runtime; however:
    Package default-jre is not installed.
    Package java2-runtime is not installed.
    Package openjdk-7-jre:i386 which provides java2-runtime is not configured yet.

    dpkg: error processing libatk-wrapper-java-jni:i386 (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libatk-wrapper-java:
    libatk-wrapper-java depends on default-jre | java2-runtime; however:
    Package default-jre is not installed.
    Package java2-runtime is not installed.
    Package openjdk-7-jre:i386 which provides java2-runtime is not configured yet.

    dpkg: error processing libatk-wrapper-java (--configure):
    dependency problems - leaving unconfigured

    And when I go to Updates it shows:

    The following packages have unmet dependencies:


    openjdk-7-jre-headless: Depends: openjdk-7-jre-lib (= 7u15-2.3.7-0ubuntu1~12.10.1) but it is not installed
    Depends: libjpeg8 (>= 8c) but 8c-2ubuntu7 is installed
    Depends: libgcc1 (>= 1:4.1.1) but 1:4.7.2-2ubuntu1 is installed
    Depends: zlib1g (>= 1:1.1.4) but 1:1.2.7.dfsg-13 is installed

    Any quick solution guys and step by step
    I am totally beginner
    Last edited by Ali paco; April 8th, 2013 at 08:28 PM. Reason: Removed most of the formatting

  2. #2
    Join Date
    Nov 2012
    Location
    Halloween Town
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Hi

    I'm assuming you were trying to install openjdk-7.

    How did you made it? Can you reproduce the steps?
    Please mark your thread as solved if you get a satisfactory response
    PopularPages - A Ubuntu Documentation Search Tool
    Ubuntu membership via Forums contributions

  3. #3
    Join Date
    Oct 2009
    Location
    Reykjavík, Ísland
    Beans
    11,986
    Distro
    Lubuntu 16.10 Yakkety Yak

    Re: Hi

    As you know
    http://ubuntuforums.org/showthread.p...1#post12593105
    we prefer an informative thread title. It helps people in the future which might have the same problem.

    Also please stick to standard formatting.
    Bringing old hardware back to life. About problems due to upgrading.
    Please visit Quick Links -> Unanswered Posts
    Don't use this space for a list of your hardware. It only creates false hits in the search engines.

  4. #4
    Join Date
    Apr 2013
    Beans
    7

    Re: Hi

    I went to Ubuntu software center and i searched for Java package I thought I didn't had Java
    And this happened

    What should I do

  5. #5
    Join Date
    Nov 2012
    Location
    Halloween Town
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: The following packages have unmet dependencies

    At the terminal run these commands that will purge your system from that bad installation:
    Code:
    sudo rm /var/lib/dpkg/info/oracle-java7-installer*
    sudo apt-get purge oracle-java7-installer*
    sudo rm /etc/apt/sources.list.d/*java*
    After that been done lets get Java installed. Run one by one these commands at the terminal:
    Code:
    sudo apt-get update
    sudo add-apt-repository ppa:webupd8team/java
    sudo apt-get update
    sudo apt-get install oracle-java7-installer
    Edit: Let us know how it went.
    Please mark your thread as solved if you get a satisfactory response
    PopularPages - A Ubuntu Documentation Search Tool
    Ubuntu membership via Forums contributions

  6. #6
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    7,175
    Distro
    Ubuntu

    Re: The following packages have unmet dependencies

    Please re-read this, especially section 2.

    http://ubuntuforums.org/misc.php?do=showrules

    When your review is done try these
    Code:
    sudo apt-get clean
    Code:
    sudo apt-get update
    Code:
    sudo apt-get install -f
    And you can reply with the outputs.
    Use the code tags as suggested in the link.
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  7. #7
    Join Date
    Apr 2013
    Beans
    7

    Re: The following packages have unmet dependencies

    Thanks guys all of you i really appreciate this

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •