Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Nautilus Shows Hidden Folders By Default

  1. #1
    Join Date
    Feb 2011
    Location
    Boston, MA
    Beans
    134
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Nautilus Shows Hidden Folders By Default

    Using Ubuntu 13.04. Like the title says, when I open Nautilus it automatically shows all the hidden folders. Any ways to get back to not showing them by default?

  2. #2
    Join Date
    Feb 2010
    Location
    Summerwind
    Beans
    12,761
    Distro
    Ubuntu Development Release

    Re: Nautilus Shows Hidden Folders By Default

    Try Ctrl + h , hidden folder view is persistent on Nautilus 3.6.3 like Thunar.

    Edit: Make sure show hidden is not enabled in preferences either.
    Last edited by Frogs Hair; April 7th, 2013 at 10:38 PM.
    “Start where you are. Use what you have. Do what you can".

    Ubuntu Documentation Search: Popular Pages
    Ubuntu: Security Basics
    Ubuntu: Manual

  3. #3
    Join Date
    Feb 2011
    Location
    Boston, MA
    Beans
    134
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Nautilus Shows Hidden Folders By Default

    No, it's not here for some reason. If I press ctrl+h to hide the folders, close the windows and reopen it, they're all showing again.

    nautilus --version shows I'm using Nautilus 3.8.0

  4. #4
    Join Date
    Apr 2013
    Location
    Queens, NY
    Beans
    44
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Nautilus Shows Hidden Folders By Default

    Did you do a sudo apt-get update, then try to remove and reinstall Nautilus? If you have trouble with the command line use the 'Synaptic Package Manager' and mark nautilus for 'complete removal' then reboot, then do a reinstall. If you don't have the synaptic package manager you can get it form the software manager. In Synaptic when you mark something it gives you a choice of whether to remove, completely remove, or install. It also fixes broken packages. You can try to type in Nautilus in the search box then click on broken on the left side of the pane, it may fix it in Synaptic.
    Last edited by breezypt; April 8th, 2013 at 12:43 AM.

  5. #5
    Join Date
    Apr 2012
    Beans
    7,174

    Re: Nautilus Shows Hidden Folders By Default

    what does

    Code:
    dconf dump /org/gnome/nautilus/preferences/
    say?

  6. #6
    Join Date
    Feb 2010
    Location
    Summerwind
    Beans
    12,761
    Distro
    Ubuntu Development Release

    Re: Nautilus Shows Hidden Folders By Default

    Quote Originally Posted by Rikeshar View Post
    No, it's not here for some reason. If I press ctrl+h to hide the folders, close the windows and reopen it, they're all showing again.

    nautilus --version shows I'm using Nautilus 3.8.0
    I am running 13.04 and didn't upgrade to gnome 3.8 so I have 3.6 .
    Last edited by Frogs Hair; April 8th, 2013 at 02:40 AM.
    “Start where you are. Use what you have. Do what you can".

    Ubuntu Documentation Search: Popular Pages
    Ubuntu: Security Basics
    Ubuntu: Manual

  7. #7
    Join Date
    Oct 2008
    Beans
    3,509

    Re: Nautilus Shows Hidden Folders By Default

    Using the terminal, get your current dconf setting...
    Code:
    gsettings get org.gnome.nautilus.preferences show-hidden-files
    Reset to default (false)...
    Code:
    gsettings reset org.gnome.nautilus.preferences show-hidden-files

    Check again (should show false)...
    Code:
    gsettings get org.gnome.nautilus.preferences show-hidden-files
    Should now always revert to not showing hidden files once nautilus is closed.
    Last edited by stinkeye; April 8th, 2013 at 05:43 AM.

  8. #8
    Join Date
    Feb 2011
    Location
    Boston, MA
    Beans
    134
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Nautilus Shows Hidden Folders By Default

    Well,
    Code:
    gsettings get org.gnome.nautilus.preferences show-hidden-files
    Does return false, yet it is still showing them by default.

    This:
    Code:
    dconf dump /org/gnome/nautilus/preferences/


    returns:
    Code:
    default-folder-viewer='icon-view'
    always-use-browser=true
    click-policy='double'
    show-advanced-permissions=false
    enable-delete=false

  9. #9
    Join Date
    Dec 2012
    Beans
    4

    Re: Nautilus Shows Hidden Folders By Default

    I have the same problem too!
    Even if I uncheck the option, Hidden files are display again on the next nautilus window I open! :/

    Code:
    $ dconf dump /org/gnome/nautilus/preferences/
        show-hidden-files=false
        always-use-location-entry=true
        sort-directories-first=true
    
    $ gsettings get org.gnome.nautilus.preferences show-hidden-files
        False
    EDIT: https://bugs.launchpad.net/ubuntu-gnome/+bug/1171852
    Last edited by malabarth; April 23rd, 2013 at 02:10 PM.

  10. #10
    Join Date
    May 2007
    Beans
    1

    Re: Nautilus Shows Hidden Folders By Default

    open terminal and type:
    dconf-editor
    Enter and then:
    org->gtk->settings->file-chooser
    uncheck show-hidden

    Have a nice day!

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •