Stop me if you heard this one....

I built this computer about a month ago using the Gigabyte GA-990FXA-UD3 rev 3 motherboard.
I initially put in Windows 7 64 bit professional. everthing went well, not a problem.

Then I decided to go ahead and install Ubuntu 12.10. From what I've read online, this wasn't for the faint of heart among those who own a GA-990FXA-UD3 but did it anyway.

Big suprise, the wired network won't connect. It tries, doesn't get a connection. then it disables, then tries again.

I have done the following steps to no success

  • I have swapped out the seemingly faulty r8169.ko and replaced it with the r8168.ko available Here.
  • I've tried just about every method from what is directed in the README in the tarball, to various methods mentioned elsewhere on the web.
  • I've attempted to reboot even unplugging the machine from the wall for a bit.
  • I have tried installing 12.04
  • I managed to find an old Netgear WG111 usb adapter and got it to work thus giving me internet. So I did a clean install of Ubuntu with network connection (preivious installs did not have a network connection), then updated the system upon first boot. FYI: after the update the ethernet was still using r8169 so updated it with r8168.
  • I've set IPv6 to "Ignore"
  • I've attempted the
    HTML Code:
    sudo     modprobe r8168
  • I have tried using alternatives to the default network manager like Wicd


Stll the result is the same. The wired network attempts to connect, fails, a pop up states "Wired network disconnected" then tries again.

When I unplug the cable from the network port, it does detect that it's been disconnected and discontinues the cycle of attempting to connect.

I have manually put in the connection details into the network configuration, this said I was connected but I had no network access.

I've edited etc/network/Interfaces and put in the following lines

HTML Code:
# The Ethernet card
auto eth0
iface eth0 inet dhcp
When I rebooted the splash screen comes up and tells me that it is waiting for a network connection. It never finds one and then boots up without any network connection (wireless or wired) nor can I configure it until a comment or remove the eth0 lines and reboot.

The Win 7 64 pro install on the same machine using the same cable is able to connect no problem.

I have a Playstation 3 that is wired to the same gateway and it connects no problem.

I have two laptops, two android smartphones, and a Win764pro machine that connect, no problem, wireless, to the same gateway (a Motorola SBG6480 D3 cable gateway).

In fact I had an older machine that I had Ubuntu 12.04 on it and it was able to connect to the same gateway some months ago.

Too much detail? I'm in technical support so I tend to answer questions before they are asked Speaking of which..

A common problem I know, but it may be related.. the networking stop and restart command lines crash ubuntu in my case.

Here is yet more info

I type in the "ifdown" and "ifup" command line and get the following
HTML Code:
$ sudo ifdown eth0
ifdown: interface eth0 not configured
$ sudo ifup eth0
Ignoring unknown interface eth0=eth0.
However...
HTML Code:
$ sudo ifconfig eth0 down
$ sudo ifconfig eth0 up
$
Ifconfig -v output
HTML Code:
eth0      Link encap:Ethernet  HWaddr 94:de:80:0b:90:fd  
          inet6 addr: fe80::96de:80ff:fe0b:90fd/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:1748 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:60 (60.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:3419 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3419 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:318849 (318.8 KB)  TX bytes:318849 (318.8 KB)

wlan0     Link encap:Ethernet  HWaddr 00:1b:2f:73:cd:80  
          inet addr:192.168.0.9  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::21b:2fff:fe73:cd80/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:19332 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14038 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:17515782 (17.5 MB)  TX bytes:2803016 (2.8 MB)
lspci -v

HTML Code:
xpress Gigabit Ethernet controller (rev 06)
    Subsystem: Giga-byte Technology GA-EP45-DS5/GA-EG45M-DS2H Motherboard
    Flags: bus master, fast devsel, latency 0, IRQ 75
    I/O ports at a000 [size=256]
    Memory at da104000 (64-bit, prefetchable) [size=4K]
    Memory at da100000 (64-bit, prefetchable) [size=16K]
    Capabilities: [40] Power Management version 3
    Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Capabilities: [70] Express Endpoint, MSI 01
    Capabilities: [b0] MSI-X: Enable- Count=4 Masked-
    Capabilities: [d0] Vital Product Data
    Capabilities: [100] Advanced Error Reporting
    Capabilities: [140] Virtual Channel
    Capabilities: [160] Device Serial Number 00-00-00-00-68-4c-e0-00
    Kernel driver in use: r8168
    Kernel modules: r8168
looks like the componant is using the correct driver.

So after scouring the net I've tried everything, Any assistance would be greatly appreciated. I'd rather not switch flavors, and since this is giving me the headache my natural inclination as a per my occupation is to take an issue by the horns and figure out a solution rather than cast it on the trash heap. Also I am a community guy so I'd like to beable to compile solutions in order to make this motherboard work for others who have such aspirations.

Thanks