Results 1 to 3 of 3

Thread: Creative Labs X-Fi card not recognized Dell Precision 390

  1. #1
    Join Date
    Apr 2013
    Location
    Long Beach, California
    Beans
    147
    Distro
    Ubuntu Studio

    Question Creative Labs X-Fi card not recognized Dell Precision 390

    Hi everyone, I've been searching this one for a little while, and there seems to be an old beta drive from Creative which is difficult to find. Anyone has ever made a mid 2005~ Creative Labs X-Fi card working on a Dell Precision 390?

    Thanks, NIcolas
    Last edited by 33Nicolas; April 14th, 2013 at 01:08 PM.

  2. #2
    Join Date
    Apr 2013
    Location
    Long Beach, California
    Beans
    147
    Distro
    Ubuntu Studio

    Re: Creative Labs X-Fi card not recognized Dell Precision 390

    Figured it out. Thanks.

  3. #3
    Join Date
    Oct 2009
    Location
    Reykjavík, Ísland
    Beans
    12,637
    Distro
    Lubuntu 17.10 Artful Aardvark

    Re: Creative Labs X-Fi card not recognized Dell Precision 390

    Good, please post the solution for others to use.
    If you install Buntu 17.10 remember to download a new ISO file.

    Old ISO files might contain a bug which can damage UEFI hardware. Updating an existing installation and upgrading to 17.10 (if one has faith in upgrades in general) are safe.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •