Results 1 to 2 of 2

Thread: Can't install these packages

  1. #1
    Join Date
    May 2010

    Question Can't install these packages

    Hi please help me.

    ahmed@ahmed-PH67A-UD3-B3:~$ sudo apt-get install git-core gnupg flex bison gperf libsdl1.2-dev libesd0-dev libwxgtk2.8-dev squashfs-tools build-essential zip curl
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    zip is already the newest version.
    gnupg is already the newest version.
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    curl : Depends: libcurl3 (= 7.27.0-1ubuntu1) but 7.27.0-1ubuntu1.1 is to be installed
    libsdl1.2-dev : Depends: libglu1-mesa-dev but it is not going to be installed or
    Depends: libpulse-dev but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

    And thank you.

  2. #2
    Join Date
    Feb 2013

    Re: Can't install these packages

    Let's tackle them one by one. First, install the packages that can be installed:
    sudo apt-get update
    sudo apt-get install build-essential git-core flex bison gperf lib{esd0,wxgtk2.8}-dev squashfs-tools
    Then try:
    sudo apt-get install libcurl3 curl
    sudo apt-get install lib{pulse,glu1-mesa,sdl1.2}-dev
    Last edited by schragge; April 3rd, 2013 at 03:06 PM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts