Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: Option 66 for DHCP server

  1. #11
    Join Date
    Nov 2009
    Location
    Mataro, Spain
    Beans
    13,215
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Option 66 for DHCP server

    Quote Originally Posted by jonobr View Post
    Hello


    Im not sure why the :5062 is in there.
    tftp runs on port 69 UDP

    Port 5060 is the SIP signalling port which sounds close to your 5062, but IM not sure why the port number is defined there.
    Im pretty sure adding :5062 is stopping DHCP from starting
    My guess would be they are trying to say to the phone(s): connect to ip 66.209.232.198 on port 5062. Many companies replace the default 5060 SIP port with another one, for protection I guess. It should work fine as long as you tell the phones where to look for the PBX. However, I'm not sure this should be done with the TFTP command.

    I would expect the TFTP to only supply the TFTP server (and maybe a filename with option 67 as mentioned), and then inside the config file that the phone pulls from the TFTP you should put the port you want to use for the phone to communicate with the PBX.

    I can't say I'm expert on this but this TFTP command looks weird to me.

    On top of that, you need to be sure of the physical layout you have. For example, if your phones are somehow in another VLAN (through the dark fibre you mentioned), putting this option on your local network dhcp will not help you, even if you get the syntax right and the dhcp starts OK. You need the option on which ever dhcp server that is serving the phones.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 14.04 LTS 64bit & Windows 10 Pro 64bit

  2. #12
    Join Date
    Apr 2013
    Beans
    7

    Re: Option 66 for DHCP server

    The DHCP server I am configuring with the Option 66 is the one that serves the phones. They make the connection to the system through the fiber to the PBX on the other end.

    Thanks again for the help, still working on it.

  3. #13
    Join Date
    Nov 2009
    Location
    Mataro, Spain
    Beans
    13,215
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Option 66 for DHCP server

    How about a different type of test? Can you ping the PBX IP/hostname from your site using a machine in the phone VLAN?

    Can you set a phone with manual settings just to see if it will register correctly on the PBX?

    You did try the tftp option with only the IP without the port at the end right?
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 14.04 LTS 64bit & Windows 10 Pro 64bit

  4. #14
    Join Date
    Apr 2013
    Beans
    7

    Re: Option 66 for DHCP server

    As far as I am aware, it is working now. I had to change it to:
    option tftp-server-name "66.209.232.198:5062";

    this now makes the phone boot into the option 66.

    Big Thanks to all the help here.

  5. #15
    Join Date
    Nov 2009
    Location
    Mataro, Spain
    Beans
    13,215
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Option 66 for DHCP server

    Great.

    I think someone mentioned before putting the value in quotes.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 14.04 LTS 64bit & Windows 10 Pro 64bit

  6. #16
    Join Date
    Nov 2006
    Location
    Craggy Island.
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Option 66 for DHCP server

    I think the reason is that phones like the cisco 79XX series phones can tftp their default boot params and basic configs from the PBX or other tftp server.
    Im guessing the operation of the buttons, logo on the LCD screen, basic default feature set can all be centralized on a tftp server,
    just a guess though
    You can tell a man who boozes by the company he chooses, as the pig got up and slowly walked away.

  7. #17
    Join Date
    Apr 2013
    Beans
    7

    Re: Option 66 for DHCP server

    I was told today that tftp-server-name (option 66) does not work with the phones we are using (no idea why he said to use option 66 when it would not work). I was told it needs to be sip:proxy@66.209.232.198:5062 instead. Can I still do this in the DHCP server and if so, how?

    Thanks

  8. #18
    Join Date
    Nov 2009
    Location
    Mataro, Spain
    Beans
    13,215
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Option 66 for DHCP server

    Try putting all of it as a value inside the quotes. But the option type still needs to be tftp-server-name which is equivalent to option 66 or they need to give you instructions of another dhcp option to use.

    If we are not talking about a large number of phones, you might be better off doing things manually. If that is the address of the SIP server you can put that manually in most phones.

    Autoconfiguration has it's benefits especially in large deployments, but sometimes it creates hassles too. In our small office the Thompsons we have boot much faster without TFTP on boot, and with manual configuration. Plus, I had the feeling the boot TFTP configuration wasn't even done properly by the previous administrator. It's a small number of phones so I just scrapped it all together, works great and boots faster with manual config.

    EDIT PS. I was under the impression they know what they are talking about, but we might have been wrong. You said it yourself, first they say use that option, then they say it can't work. I am still wondering if that address is the PBX and the port it listens on. In that case, it shouldn't be in option 66 at all.

    My logic is that you would use option 66 for IP phones to tell them where to download their config file from. And inside this config file you have the server address. You don't pass the PBX server to the phone with option 66 because the PBX usually is not booting the phone, especially not on port 5062. With option 66 you pass the TFTP/BOOTP server address. In this case it might be the same as the PBX but I'm starting to doubt that.

    If you know how to configure that model manually, do a quick test. Go into the SIP config and put that IP and port for the server and proxy values. But you will also need a correct network config for the phone to be able to communicate in your LAN. See if that makes the phone work. If it does, that's the PBX address and I doubt it needs to be in option 66.
    Last edited by darkod; April 4th, 2013 at 03:39 PM.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 14.04 LTS 64bit & Windows 10 Pro 64bit

  9. #19
    Join Date
    Nov 2006
    Location
    Craggy Island.
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Option 66 for DHCP server

    Hello


    I dont hold any hope for your vendor.
    He seems a little lost.

    I think what he may be asking you to do is to configure the phones to talk to their PBX, or, more likely he is giving you a proxy to talk to on the cloud.

    The line he is giving you siproxy@66.209.232.198:5062 , seems more like the structure of a sip invite or registration packet rather then anything to do with DHCP or anything like that.

    To make a call using sip, you send an invite.
    The "to" address in the invite is <endpoint>@Sipserver/proxyIP:5060

    Looking at your line
    the ip address of the sip server is 66.209.232.198 -
    This belongs to http://www.iquest.net/ in Indiana.
    It looks like these people are cloud services folks.

    The port number is usually 5060 but they have given you 5062 which is ok,

    If you have a IP PBX server on your system, it looks as if they want you to point your sip server to theirs so they can handle your voice calls.

    If you dont have a PBX server and your point all your phones to the "cloud" then that would also make sense.

    Going back to the root of your problem, it looks as if they are trying to get you to setup something specific on your network IT infrastructure to enable voice services, but the guy may be a savvy Voip guy but not an IT guy.


    I would recommend you ask what this 66.x.x.x server is,
    Is it the registrar? IS it the Sip proxy/server?
    What is missing from the current setup that is stopping this from working?
    What do I need to do my end to get this operational?
    Explain what is required on the client to get this working and then we (you) could figure out how to configure or change or network to get this working.

    The guy saying add this line to your "DHCP" is probably what you need now,
    I would recommend he give you a technical description of what he needs from your IT infrastructure in order to get this working.
    Then you can figure out how to get that done
    You can tell a man who boozes by the company he chooses, as the pig got up and slowly walked away.

  10. #20
    Join Date
    Apr 2013
    Beans
    7

    Re: Option 66 for DHCP server

    I am in aggreement and very displeased. After talks with them, they did not listen to what our connectivity was and are using cloud instead of the layer 2 fiber path. All this was a waste of time. Thanks for all the help.

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •