I have a Dlink NAS DNS-325. When I browse files it's there, absolutely fine, but when I want to connect from an application, such as Thunderbird (or anything else) the network is just not available. This is not just the NAS that's not available, it's the whole network, but the NAS is what concerns me at the moment.

I have been told I need to mount the NAS at startup, and have been directed to a site "http://ubuntuforums.org/showthread.php?t=249889", which instructs me to run the commands

$ sudo apt-get update
$ sudo apt-get install nfs-common

Following is the result:

bigbin@Bigbin-Ubuntu:~$ sudo apt-get update
[sudo] password for bigbin:
Hit http://gb.archive.ubuntu.com precise Release.gpg
Hit http://gb.archive.ubuntu.com precise-updates Release.gpg
Hit http://gb.archive.ubuntu.com precise Release
Hit http://gb.archive.ubuntu.com precise-updates Release
Get:1 http://extras.ubuntu.com precise Release.gpg [72 B]
Hit http://security.ubuntu.com precise-security Release.gpg
Hit http://gb.archive.ubuntu.com precise/main Sources
Hit http://gb.archive.ubuntu.com precise/restricted Sources
Hit http://gb.archive.ubuntu.com precise/universe Sources
Hit http://gb.archive.ubuntu.com precise/multiverse Sources
Hit http://gb.archive.ubuntu.com precise/main i386 Packages
Hit http://gb.archive.ubuntu.com precise/restricted i386 Packages
Hit http://security.ubuntu.com precise-security Release
Hit http://gb.archive.ubuntu.com precise/universe i386 Packages
Hit http://gb.archive.ubuntu.com precise/multiverse i386 Packages
Hit http://gb.archive.ubuntu.com precise/main TranslationIndex
Hit http://gb.archive.ubuntu.com precise/multiverse TranslationIndex
Hit http://gb.archive.ubuntu.com precise/restricted TranslationIndex
Hit http://gb.archive.ubuntu.com precise/universe TranslationIndex
Hit http://gb.archive.ubuntu.com precise-updates/main Sources
Hit http://gb.archive.ubuntu.com precise-updates/restricted Sources
Hit http://gb.archive.ubuntu.com precise-updates/universe Sources
Hit http://extras.ubuntu.com precise Release
Hit http://security.ubuntu.com precise-security/main Sources
Hit http://gb.archive.ubuntu.com precise-updates/multiverse Sources
Hit http://gb.archive.ubuntu.com precise-updates/main i386 Packages
Hit http://gb.archive.ubuntu.com precise-updates/restricted i386 Packages
Hit http://gb.archive.ubuntu.com precise-updates/universe i386 Packages
Hit http://gb.archive.ubuntu.com precise-updates/multiverse i386 Packages
Hit http://security.ubuntu.com precise-security/restricted Sources
Hit http://security.ubuntu.com precise-security/universe Sources
Hit http://security.ubuntu.com precise-security/multiverse Sources
Hit http://security.ubuntu.com precise-security/main i386 Packages
Hit http://security.ubuntu.com precise-security/restricted i386 Packages
Hit http://security.ubuntu.com precise-security/universe i386 Packages
Hit http://security.ubuntu.com precise-security/multiverse i386 Packages
Hit http://security.ubuntu.com precise-security/main TranslationIndex
Hit http://security.ubuntu.com precise-security/multiverse TranslationIndex
Hit http://security.ubuntu.com precise-security/restricted TranslationIndex
Hit http://extras.ubuntu.com precise/main Sources
Hit http://gb.archive.ubuntu.com precise-updates/main TranslationIndex
Hit http://gb.archive.ubuntu.com precise-updates/multiverse TranslationIndex
Hit http://gb.archive.ubuntu.com precise-updates/restricted TranslationIndex
Hit http://gb.archive.ubuntu.com precise-updates/universe TranslationIndex
Hit http://gb.archive.ubuntu.com precise/main Translation-en_GB
Hit http://security.ubuntu.com precise-security/universe TranslationIndex
Hit http://extras.ubuntu.com precise/main i386 Packages
Ign http://extras.ubuntu.com precise/main TranslationIndex
Hit http://gb.archive.ubuntu.com precise/main Translation-en
Hit http://gb.archive.ubuntu.com precise/multiverse Translation-en_GB
Hit http://gb.archive.ubuntu.com precise/multiverse Translation-en
Hit http://gb.archive.ubuntu.com precise/restricted Translation-en_GB
Hit http://gb.archive.ubuntu.com precise/restricted Translation-en
Hit http://security.ubuntu.com precise-security/main Translation-en
Hit http://security.ubuntu.com precise-security/multiverse Translation-en
Hit http://gb.archive.ubuntu.com precise/universe Translation-en_GB
Hit http://gb.archive.ubuntu.com precise/universe Translation-en
Hit http://gb.archive.ubuntu.com precise-updates/main Translation-en_GB
Hit http://gb.archive.ubuntu.com precise-updates/main Translation-en
Hit http://gb.archive.ubuntu.com precise-updates/multiverse Translation-en_GB
Hit http://security.ubuntu.com precise-security/restricted Translation-en
Hit http://gb.archive.ubuntu.com precise-updates/multiverse Translation-en
Hit http://gb.archive.ubuntu.com precise-updates/restricted Translation-en_GB
Hit http://gb.archive.ubuntu.com precise-updates/restricted Translation-en
Hit http://gb.archive.ubuntu.com precise-updates/universe Translation-en_GB
Hit http://gb.archive.ubuntu.com precise-updates/universe Translation-en
Hit http://security.ubuntu.com precise-security/universe Translation-en
Ign http://extras.ubuntu.com precise/main Translation-en_GB
Ign http://extras.ubuntu.com precise/main Translation-en
Fetched 72 B in 31s (2 B/s)
Reading package lists... Done
bigbin@Bigbin-Ubuntu:~$ sudo apt-get install nfs-common
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
libunity6 linux-headers-3.2.0-24 kde-l10n-engb screen-resolution-extra
linux-headers-3.2.0-24-generic-pae
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
libgssglue1 libnfsidmap2 libtirpc1 rpcbind
The following NEW packages will be installed
libgssglue1 libnfsidmap2 libtirpc1 nfs-common rpcbind
0 upgraded, 5 newly installed, 0 to remove and 22 not upgraded.
Need to get 413 kB of archives.
After this operation, 1,298 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://gb.archive.ubuntu.com/ubuntu/ precise-updates/main libgssglue1 i386 0.3-4ubuntu0.1 [22.0 kB]
Get:2 http://gb.archive.ubuntu.com/ubuntu/ precise/main libtirpc1 i386 0.2.2-5 [84.4 kB]
Get:3 http://gb.archive.ubuntu.com/ubuntu/ precise-updates/main rpcbind i386 0.2.0-7ubuntu1.2 [41.9 kB]
Get:4 http://gb.archive.ubuntu.com/ubuntu/ precise/main libnfsidmap2 i386 0.25-1ubuntu2 [30.6 kB]
Get:5 http://gb.archive.ubuntu.com/ubuntu/ precise-updates/main nfs-common i386 1:1.2.5-3ubuntu3.1 [234 kB]
Fetched 413 kB in 16s (25.1 kB/s)
Selecting previously unselected package libgssglue1.
(Reading database ... 544091 files and directories currently installed.)
Unpacking libgssglue1 (from .../libgssglue1_0.3-4ubuntu0.1_i386.deb) ...
Selecting previously unselected package libtirpc1.
Unpacking libtirpc1 (from .../libtirpc1_0.2.2-5_i386.deb) ...
Selecting previously unselected package rpcbind.
Unpacking rpcbind (from .../rpcbind_0.2.0-7ubuntu1.2_i386.deb) ...
Selecting previously unselected package libnfsidmap2.
Unpacking libnfsidmap2 (from .../libnfsidmap2_0.25-1ubuntu2_i386.deb) ...
Selecting previously unselected package nfs-common.
Unpacking nfs-common (from .../nfs-common_1%3a1.2.5-3ubuntu3.1_i386.deb) ...
Processing triggers for man-db ...
Processing triggers for ureadahead ...
Setting up libgssglue1 (0.3-4ubuntu0.1) ...
Setting up libtirpc1 (0.2.2-5) ...
Setting up rpcbind (0.2.0-7ubuntu1.2) ...
Removing any system startup links for /etc/init.d/rpcbind ...
portmap start/running, process 17189
Setting up libnfsidmap2 (0.25-1ubuntu2) ...
Setting up nfs-common (1:1.2.5-3ubuntu3.1) ...

Creating config file /etc/idmapd.conf with new version

Creating config file /etc/default/nfs-common with new version
Adding system user `statd' (UID 117) ...
Adding new user `statd' (UID 117) with group `nogroup' ...
Not creating home directory `/var/lib/nfs'.
statd start/running, process 17423
gssd stop/pre-start, process 17452
idmapd start/running, process 17496
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
bigbin@Bigbin-Ubuntu:~$ ^C

Then tried to view the location:

bigbin@Bigbin-Ubuntu:~$ showmount -e 192.168.1.73
clnt_create: RPC: Port mapper failure - Unable to receive: errno 111 (Connection refused)

Then tried to mount the NAS in a directory called nfs:

bigbin@Bigbin-Ubuntu:~$ sudo mkdir /nfs
[sudo] password for bigbin:
bigbin@Bigbin-Ubuntu:~$ cd /nfs
bigbin@Bigbin-Ubuntu:/nfs$ cd /
bigbin@Bigbin-Ubuntu:/$ sudo mount -o soft,intr,rsize=8192,wsize=8192 192.168.1.73:/volume1 /nfs
mount.nfs: Connection timed out

Can anyone help please. This is one of the problems preventing my migration from Windows, though by no means the only one.

regards

Phil Binner