Results 1 to 2 of 2

Thread: lightdm doesn't start automatically

  1. #1
    Join Date
    Apr 2007

    lightdm doesn't start automatically


    I know this problem has been discussed before in other threads, but none of them seems to solve my case.

    The problem is lightdm doesn't start automatically, and it stops at the terminal. Then I have to manually do a "sudo service lightdm start" to get it started automatically.

    I referred this thread, but still the solution shows doesn't solve my case:

    * Setting sensors limits ^[[170G ^M^[[164G[ OK ]
    * Stopping System V initialisation compatibility^[[74G[ OK ]
    Rather than invoking init scripts through /etc/init.d, use the service(8)
    utility, e.g. service S20lightdm start
    * Starting KVM^[[74G[ OK ]
    * Starting System V runlevel compatibility^[[74G[ OK ]
    I tried the below:
    $ sudo sudo update-rc.d lightdm defaults
    update-rc.d: warning: /etc/init.d/lightdm missing LSB information
    update-rc.d: see <>
    System start/stop links for /etc/init.d/lightdm already exist.
    $ cat /etc/X11/default-display-manager
    I tried dpkg-reconfigure of lightdm, uninstall-reinstall lightdm, still it doesn't solve my issue.

    Anyone has any suggestion. Thanks.

  2. #2
    Join Date
    Apr 2012

    Re: lightdm doesn't start automatically

    You could look in /var/log/lightdm/lightdm.log and /var/log/lightdm/x-0-greeter.log as well, that's where messages about the actual lightdm startup would go I think


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts