My apologies if this has been addressed. If so please point me to the correct posts. I have been reading until I am cross-eyed.

I just got a Dell Inspiron 660s and wanted to dual boot with ubuntu. First go round, I ended up erasing windows and had to ask Dell for the recovery media disk (thankfully it worked to reinstall windows). After a few failed attempts to get both Windows and Ubuntu installed, I believe I have them in place after following this post as closely as possible http://ubuntuforums.org/showthread.php?t=2108450 , Note: when I first restarted, I saw GRUB with both ubuntu and windows listed and following what this post said, I booted to windows. I haven't seen the GRUB screen since (and it now only boots to windows). I have used the boot repair utility and first it told me that the boot files are far from the start of the disk and I may want to create a /boot partition (ext 4 >200MB, start of disk) so I did that even after getting a warning about moving the start sector of windows (no issues with booting into windows after that) This is a picture of Gparted's screen: (I do not know why they all say /boot now unless it has something to do with boot repair.)
Screenshot from 2013-03-29 15:44:58.png

Now the boot repair utility is giving me messages and I don't know what to do...

It first tells me that EFI is detected and to check my options. So clicking on advanced options this is what I get:
Screenshot from 2013-03-29 15:01:40.pngScreenshot from 2013-03-29 15:02:05.pngScreenshot from 2013-03-29 15:36:17.png
I see that "secure boot" is checked in the third picture, but when I uncheck (I do not want secure boot, correct?) it it has a "edit grub configuration file" button and I don't know what I should change in there (if I should be messing with any of it).

Please note that when I created the /boot partition it was in sda5 and I was sure it said efi as well, however now of course it does not say that. When I click apply (with settings as shown), I get this:
Screenshot from 2013-03-29 15:25:26.png
After running this script in terminal, it tells me "Grub is still present. Please try again." If I change the boot partition to sda5, I get a message: GPT detected. Please creat a BIOS-Boot partition (>1MB, unformated file system, bios_grub flag). This can be performed via tools such as Gparted. Then try again. Alternatively, you can retry after activatiing the [Separate /boot/efi partition:] option.

I also read this morning that the efi should be fat32 (which it is in sda1), so should I combine sda5 with sda1 so it's big enough (as I was instructed to make it bigger than 200MB)? At this point, I know I am going in circles, so any direction would be GREATLY appreciated.