I posted in another forum, but got no response. I will repost here, hope someone can help:

1. 2013-03-22 09:31:01 PDT

I probably won't get an answer in time, but here goes.
I'm running Ubuntu, and created a CD from an iso. I wanted to clone a 64Gb SSD to a 256Gb SSD. I didn't get how disc image worked, so I selected copy drive or partition to drive or partition. Magically, it worked. Unfortunately, the contents of the cloned drive is made up of a 64Gb partition, and a 192Gb partition. I tried using Ubuntu disk utility to get rid of the partition, but of course all the data went with it. This can't be that difficult, how do I clone my OS and data onto one partition in the new drive?


2013-03-22 09:50:08 PDT

Hi glo48
Download the Gparted iso (also available at Source Forge) and burn it to a CD. Open and resize the first partition to the full 256 gigs. Works for me... Cheers...

2013-03-22 14:24:53 PDT

I tried that using PartedMagic OS. Didn't work, I simply could not get it to resize. I went back to Ubuntu on my original 64Gb drive, deleted all the partitions, made them one partition, then formatted the drive, and now I'll try again. This can't be that hard...

2013-03-22 21:52:51 PDT

Ok, I finally did get it to clone to the whole drive, without any partitions. Which is just as well, since I could delete a partition in Gparted, but not convert it to one partition. If I remember right, I formatted the drive, mounted it, then selected option three in Clonezilla (which is incorporated into PartedMagic OS). However, then it would not boot, I just got a blinking cursor after the Bios screen. I searched around in Gparted and found something called Restore Grub bootloader. Then my 256Gb drive was able to load. Unfortunately, some things were missing, like everything in Dash Home; all my applications. All the data seemed to be there, though. Does anyone know what's going on? When I cloned the working drive to the new, larger drive, why didn't the bootloader clone as well? There's obviously something else going on, but I came from the Windoze world, so I can't figure out what it is, or how to fix it. Hope someone can help...

So that's still where I'm at. I just did a sector-by-sector clone - which takes hours, btw - and have one partition in my 256Gb (which ended up as only 239Gb, go figure), which is what I wanted. But I'm still getting the message that Clonezilla could not install Grub, which means that I will still get a blinking cursor, and if I use Grub doctor in PartedMagic OS, my Dash will still be gone, although I actually haven't tried it yet. Does anyone know what is happening, and more importantly, how to fix it? It occurred to me that I could just upgrade to the latest Ubuntu version, but I would still like to know how to fix this.