Results 1 to 3 of 3

Thread: Wireless Stopped working on a new Install After working for 5 hours - weird

  1. #1
    Join Date
    Jul 2008

    Wireless Stopped working on a new Install After working for 5 hours - weird

    As I said above it just stopped working for no good reason that I can tell. Here are some notes that may help some awesome person including the Master Chil555 to help troubleshoot.

    In a nutshell -the install went fine for a friend - 12.04 Kubuntu with absolutely no serious hiccups. I decided to take it outside to polish things off as the wireless was working fine. It stopped working an hour later - I thought it was just a temporary glitch and decided to install WICD as it is much more user friendly for the new newbie neighbour. Didn't help. Some how the wireless has become disabled

    Here are my notes so far:
    Toshiba satellite amd Athlon X2 - 6-8 years old
    *-network DISABLED
    description: Wireless interface
    physical id: 1
    bus info: usb@1:6
    logical name: wlan0
    serial: 00:16:44:1e:17:33
    capabilities: ethernet physical wireless
    configuration: broadcast=yes
    driver=rtl8187 driverversion=3.2.0-39-generic firmware=N/A link=no multicast=yes wireless=IEEE 802.11bg

    • modprobe rtl8187
    • iwconfig
    • sudo iwlist wlan0 scanning
    • sudo ifconfig wlan0 up
    ‣ wlan0: ERROR while getting interface flags: No such device
    • sudo rfkill list all
    ∘ shows NOTHING
    • sudo rfkill unblock all
    ∘ not applicable
    • cat /var/lib/NetworkManager/NetworkManager.state
    ∘ but still not working ?????????


    dmesg | grep -e rtl -e wlan
    [ 10.477959] ieee80211 phy0: hwaddr 00:16:44:1e:17:33, RTL8187BvE V0 + rtl8225z2, rfkill mask 2
    [ 10.499669] rtl8187: Customer ID is 0x04
    [ 10.499972] Registered led device: rtl8187-phy0::radio
    [ 10.500784] Registered led device: rtl8187-phy0::tx
    [ 10.502479] Registered led device: rtl8187-phy0::rx
    [ 10.503296] rtl8187: wireless switch is on
    [ 10.503560] usbcore: registered new interface driver rtl8187
    [ 22.434712] ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 22.436054] ADDRCONF(NETDEV_UP): wlan0: link is not ready

    still not working

    wicd had nothing in prefernces for "Wireless Interface" so I put in wlan0
    - no help

    there is a switch on the front bottom which is turned on and has a "Yellow" light - I don't know if was ever green but it is in the on position.
    As well, WICD has an active option to turn Wireless Off - which suggests it's on, and if I do turn it off it then has the option to turn it ON - but doesn;t help
    I will post more as I do more troubleshooting
    Thanks again to Chil555

    Last edited by; March 29th, 2013 at 01:54 AM. Reason: more infpo

  2. #2
    Join Date
    Jul 2008

    Re: Wireless Stopped working on a new Install After working for 5 hours - weird

    Bump ?? !!

    Anyone out there in cyberland with any suggestions - I will try a re-install to see if that fixes it - since I don't have any oher leads. I will post results.

    Thanks in advance to any one that helps this Good Friday Birthday Boy and a perspective new Linix User that this is for.

    Cheers, Mark

  3. #3
    Join Date
    Jul 2008

    Solved - Wireless Stopped working on a new Install After working for 5 hours - weird

    without any further suggestions I thought I would try a re-install

    and it worked !

    I sure wish I knew what caused the problem, but Oh well at least I can give her back her 8 year old computer working better than the day she bought it HAHA

    She will be so Happy with this Kubuntu and my tweaks.

    Cool- and Thanks again Chili555 (Bill)



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts