Results 1 to 10 of 11

Thread: Dual OS Infinite Reboot Loop Can't get to GRUB

Threaded View

  1. #1
    Join Date
    Dec 2012

    Dual OS Infinite Reboot Loop Can't get to GRUB


    I have my machine setup to dual boot Windows 7 and Ubuntu 12.04 via grub. However, after I did a Windows Update today, it went straight to grub rescue. I messed with "set root" a little, and tried to reboot again. It then got to grub and I was able to boot Windows normally. Then I tried to reboot again, and now, it doesn't even go to grub or grub rescue. It just continuously reboots.

    I attempted to purge and re-install grub via boot-repair from live-USB, but nothing has changed. The following is the bootinfoscript:

    I have a weak understanding of bootloaders, so any suggestions would be greatly appreciated! I have no idea which direction to investigate next.

    Please help! I urgently need the laptop this week. Thank you in advance!

    Extra history that may or may not help:
    After I first set up the dual boot, I had problems going from Windows to Ubuntu, not the other way around though. When I would try to boot into Linux, I would get a:

    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

    I would then hard restart, and grub would load again, and then I would be able to boot into linux normally. After several months, the same procedure would cause a different error. Instead of a Kernel panic, I got:

    error: invalid arch independent ELF magic

    Again, I would do a hard reset, and then I would be able to boot normally, so I ignored this problem for a while until now.
    Last edited by jchan91; March 24th, 2013 at 03:39 AM.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts