Results 1 to 5 of 5

Thread: [?] Can't resolve hostname on local network

Threaded View

  1. #1
    Join Date
    May 2008
    Ubuntu 12.10 Quantal Quetzal

    Question [?] Can't resolve hostname on local network

    Hi there!
    I've been fiddling around with my new RaspberryPi lately and I installed on it the transmission web client and daemon.
    Because of reasons I've been doing all the setup using windows machines for testing, and everything was fine: from all my windows (XP, 7, 8) machines I can access the transmission address (http://raspberrypi:1234/torrent/web/) with no problems at all from any browser.

    If I try accessing it from my ubuntu (10.04, 12.04) machines I just get a "page not found" error.
    I figured the problem is related to the fact I'm using the machine name (raspberrypi) instead the IP address: if I use the direct IP address (e.g.: it works flawlessly.
    I'd obviously prefer to use the hostname!

    So, how can I have ubuntu properly resolving the hostname of the raspberry (or any other host on the same local network for what matters)?

    Thanks for your attention \(^__^)/

    PS: strangely enough samba works fine with the hostname: smb://raspberrypi/pishare works just fine!

    I solved the problem adding wins in my /etc/nsswitch.conf file and installing winbind as reported on a random website.
    I have absolutely no clue about what it does but, so far, it is working on my 12.04 machine
    Last edited by balta; March 23rd, 2013 at 05:44 PM. Reason: solved

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts