Results 1 to 3 of 3

Thread: Compaq c500 / Broadcom BCM4311 wireless

  1. #1
    Join Date
    Mar 2013

    Compaq c500 / Broadcom BCM4311 wireless


    I'am new to Ubuntu, and I have been trying to get my wifi card running with Ubuntu 12.04. When I type the command lshw -C network, I can see that the card has no logical name, so I guess the driver is not installed properly. Could anyone help me further? I tried installing the Broadcom linux driver from the Broadcom website, but it seems that the code in this installation is not working for the latest versions of Ubuntu.

    description: Network controller
    product: BCM4311 802.11b/g WLAN
    vendor: Broadcom Corporation
    physical id: 0
    bus info: pci@0000:06:00.0
    version: 01
    width: 32 bits
    clock: 33MHz
    capabilities: bus_master cap_list
    configuration: driver=wl latency=0
    resources: irq:18 memory:80000000-80003fff

    Last edited by Arrowman2; March 16th, 2013 at 10:11 AM.

  2. #2
    Join Date
    Mar 2010
    Ubuntu 12.04 Precise Pangolin

    Re: Compaq c500 broadcom wireless will not work

    Welcome to the forums Arrowman2 !

    If you have a wired connection available, connect to it and do -
    sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source
    sudo apt-get install b43-fwcutter firmware-b43-installer
    Enter the above commands in a terminal (Ctrl+Alt+T), then disconnect the wired connection and try to connect via wireless. Do a restart if required.

    Post back the result. Thanks!
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  3. #3
    Join Date
    Mar 2013

    Re: Compaq c500 / Broadcom BCM4311 wireless

    Thanks very much, after a restrart the wifi works perfectly now


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts