Results 1 to 5 of 5

Thread: SAMBA Share won't mount.

  1. #1
    Join Date
    Oct 2010

    SAMBA Share won't mount.

    Hi, I had my windows shares working perfectly a few weeks ago with my two Ubuntu machines. I have changed absolutely nothing except updating Ubuntu and now they dont work. I get

    Unable to mount location

    Failed to retrieve share list from server

    When I set it up originally I had to add

    name resolve order = bcast host

    to "/etc/samba/smb.conf"

    When trying to fix this issue I have tried it with and without that modification and neither has worked (I rebooted between attempts) Since then I have added

    netbios name = computer name

    where computer name is my computer's name in Ubuntu adding that line or "name resolve order = bcast host" gets me to the error I have mentioned above. Without either nautilus will hang when attempting to browse the windows network and eventually error out without displaying any of the computers. After the addition of one of those lines I am able to browse the network's computers but am unable to connect and instead recieve above error.

    Any help would be very much appreciated.
    Last edited by Fait; February 20th, 2013 at 03:52 AM. Reason: I didn't have java script enabled, now its formated properly.

  2. #2
    Join Date
    Oct 2010

    Re: SAMBA Share won't mount.

    Any help would go a long way, even just pointing me in the right direction, thanks.

  3. #3
    Join Date
    Jan 2007
    Ubuntu 10.10 Maverick Meerkat

    Re: SAMBA Share won't mount.

    After a long and deliberate consideration I've concluded that most people today don't actually know the technology going into Ubuntu and that those that are trying are just guessing.

    I've the same issue and it was caused by Kernel 3.8.x.

    You can get this installed by when you install ubuntu 13.04 or by installing it on purpose from one of the repos.

  4. #4
    Join Date
    May 2008
    Ubuntu 14.04 Trusty Tahr

    Re: SAMBA Share won't mount.

    What were the kernel errors? How did you determine that the kernel was the problem?

    Yes, I understand Samba (SMB/CIFS).

  5. #5
    Join Date
    Jul 2010

    Re: SAMBA Share won't mount.

    Hi I had share issues in 12.04, not sure they related to upgrade but I missed something obvious. I think this highglghts the need for some decent, well publicised how-tos for Samba.

    Do you have firewall running? That will block samba. I use UFW and there's a simple command to open the appropriate ports

       sudo ufw allow samba
    This sorted it for me. The only other thing is to right click the folder you want to share, check "properties", and then "share." Are all the right boxes checked? I found I could only do this through Ubuntu - In LXDE and XFCE the file manager didn't have the same menus through propoerties.

    Hope this helps, and apologies if that was just too obvious...


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts