Results 1 to 7 of 7

Thread: Read-only system problem

  1. #1
    Join Date
    Mar 2013

    Read-only system problem

    i really don't have any idea of how to manage Ubuntu with the console. I am new in all this stuff, and i don't speak English a lot.

    My system crashed, and it doesn't let me do anything. It stays in read-only file system and i can't download or eliminate files. I tried some solutions i read, but i they didn't solve my problem!

    I did this: writing in the console "sudo fsck" (i don't know what that means)

    and the console:

    guido@Damonte:~$ sudo fsck [sudo] password for guido: sudo: no es posible abrir /var/lib/sudo/guido/0: Sistema de archivos de solo lectura fsck de util-linux 2.20.1 e2fsck 1.42.5 (29-Jul-2012) /dev/sda1: clean, 201087/7266304 files, 9690058/29045504 blocks

    I want to add, that the first time i tried this the console asked for my password and then when i put it, it said that it was wrong (it was not). Sistema de archivos de solo lectura means read only file system...

    Then i tried to put this: mount -o remount /

    guido@Damonte:~$ mount -o remount / mount: sólo el usuario root puede efectuar esta acción

    (only root user can make this action)

    I supposed root user was the main user, this is my pc, i am the only user, then i am the master root user and the creator.

    In the first days this happened, when i had turned on the pc, it said to me that the hard drive crashed, stayed in that page when Ubuntu is loading, asked me if i wanted Ubuntu to solved it. When i did that, it stayed loading again, then restart as normal but whit the same problems. After a few days this stopped and just run like if nothing happened but whit my horrible issues. (i didn't touch configurations or anything).

    If you could help it would be great, i don't ask in Spanish forums because there are less users than here. Thank you so MUCH!

  2. #2
    Join Date
    Jan 2011

    Re: Read-only system problem

    Hello, a read only filesystem is not very handy..

    On linux there is no such thing as a main user, there are regular users eventually with root permissions, and a root user.
    Root user is rarely used, but in case of trouble or special actions.

    When you want to check a filesystem, you need to be root, thats why you indeed did sudo fsck ...
    But first you need to know which filesystem is in a readonly mode. howmany partions/disks are you using.

    Please show the ouput of the command : mount . it will show what is currently mounted and how.

    Edit : I had such problem a few years ago, and it came out in the end, my disk was in a bad state, I had to replace it.
    But you can alway check ik first.
    Last edited by kuifje09; March 15th, 2013 at 10:13 PM.

  3. #3
    Join Date
    Mar 2013

    Re: Read-only system problem

    Thanks for answering!
    I did that and it showed me:

    /dev/sda1 on / type ext4 (rw,errors=remount-ro)
    proc on /proc type proc (rw,noexec,nosuid,nodev)
    sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
    none on /sys/fs/fuse/connections type fusectl (rw)
    none on /sys/kernel/debug type debugfs (rw)
    none on /sys/kernel/security type securityfs (rw)
    udev on /dev type devtmpfs (rw,mode=0755)
    devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
    tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
    none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
    none on /run/shm type tmpfs (rw,nosuid,nodev)
    none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
    gvfsd-fuse on /run/user/guido/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=guido)

    mount: aviso: /etc/mtab no se puede escribir (sistema de archivos de solo lectura).
    Es posible que la información de mount(8) no esté
    actualizada. Para tener una información real sobre los puntos de montaje del sistema
    compruebe el archivo /proc/mounts.
    (that means, mount: aviso: /etc/mtab can't write (read-only filesystem, It is posible that the information of mount (8) is not updated. For more real information about the start system facts check the file /proc/mounts).

  4. #4
    Join Date
    Jan 2011

    Re: Read-only system problem

    Ah , thats indeed /dev/sda1 that needs checking.
    /etc/* is on / which is /dev/sda1
    Probably realy bad. You cannot check a filesystem which is mounted as with a root ( / ) filesystem.
    Best options I would advise, boot from the cd, then check the /dev/sda1 and reboot.

    Hopefully it can be repaired.

    Run after booted from cd, fsck -y /dev/sda1

    It will repair, at least try to, and does not ask for each error what to do.
    Probably a lot, but it is usally too much to do it realy by hand.

    Be aware of the fact the disk can be in too badly state. but give it a chance.

  5. #5
    Join Date
    Mar 2013

    Re: Read-only system problem

    I did that. Then restart. In the Ubuntu loading screen there was a text saying that Ubuntu was checking if my hard drive was ok. Then i started and the system run normally with no problems. I watched a movie, then tried to download a torrent, and the problem appeared again! I mean, i didn't touch anything, and the problem came again.I reallyappreciate your help, this is completely strange for me. I'm just a bit disappointed because Ithough Ubuntu was more user-friendly (or the official website said that), but I installed it one month ago and this is the third time I have to reinstall it because something happens... I mean, i am not a monkey.. I don't know how to program or manage this system, but I'm not an idiot without any knowledge of pc. Do you know any other SO I can use for a low power pc? This one only has 1g of ram, one more user-friendly or without this problems. Thanks a lot for your help.

  6. #6
    Join Date
    May 2007
    Virginia, USA
    Ubuntu Mate Development Release

    Re: Read-only system problem

    If this is happening only AFTER you're downloading torrents -- you have your answer. Something in the downloading is corrupting your filesystem.
    Ubuntu 17.10 Mate, Mint 18.3 Mate; MS Win10 Pro.
    Will not respond to PM requests for support -- use the forums.

  7. #7
    Join Date
    Jan 2011

    Re: Read-only system problem

    I doubt if the torent is corrupting anything, unless you run as root...
    Also it is not related to whatever OS.
    When you check the filesystem, offline , again, does it find errors again?
    This might be caused due to a dying disk.

    I think of lookin in some of the loggings, Have a look at the logging in /var/log
    Then look in dmesg and syslog , your eye may fall on some error about writing to sda1.

    Best to roll the files and run agian what you did and caused the switch to RO.
    Maybe someone can give the command to roll the loggings ( to get a clean loggin in dmesg ansd syslog , just deleting would work also )

    Edit: logrotate -fv /etc/logrotate.d/rsyslog should do but even I tell to do it forcely, it doesn't
    Last edited by kuifje09; March 16th, 2013 at 08:15 PM.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts