Page 3 of 3 FirstFirst 123
Results 21 to 26 of 26

Thread: Unity not loading after nvidia drivers installation

  1. #21
    Join Date
    Aug 2010

    Re: Unity not loading after nvidia drivers installation

    I have the same problem. Ronacc's method dont help. when I set checkbox to install unity plugin it said it needs to install opengl plugin. I click ok install, than it wants to install expo. then expo said it needs opengl. and than i click again install opengl. window closes and still nothing is installed - unity plugin, opengl plugin, expo - nothing installed. stupid ccsm and unity..

  2. #22
    Join Date
    Oct 2007
    Ubuntu 10.10 Maverick Meerkat

    Lightbulb Re: Unity not loading after nvidia drivers installation

    That happened to me too. Deactivate plugin and activate again. It worked for me when I repeated it two or three times.
    Hope that helps.

    I also found this workaround, but I did't test it. In case it is helpful for anyone I post it here:
    dconf reset -f /org/compiz/

  3. #23
    Join Date
    Aug 2007

    Re: Unity not loading after nvidia drivers installation

    Try this from your home dir

    rm -rf .config/dconf

    unity works again, BUT you will be lost your preferences

  4. #24
    Join Date
    Feb 2010
    Nr BrandsHatch, S'oaks UK
    Lubuntu 13.04 Raring Ringtail

    Re: Unity not loading after nvidia drivers installation

    Hi! All,

    I have had the same 13.04 Blank Desktop with five different installations running different Nvidia cards and drivers, and none of the suggestions in this Thread - or others - worked for me.

    In nearly all of them I got errors similar to SkylineGTR
    Error spawning command line 'dbus-launch --autolaunch= (...): Child process exited with code 1
    Or "GLX plug-in not loaded' or 'unable to open display'.

    However, the Guest account still worked correctly, as did a new Administration account and Fallback.

    The cure of the problems on all my installations was effected by the following: run from a terminal in Fallback mode to enter the '--reset-unity' command included in Unity-Tweak-Tool:
    sudo apt-get install gnome-session-fallback # if not already installed and log-in to 'fallback'.
    sudo apt-get install unity-tweak-tool
    gksudo unity-tweak-tool --reset-unity  
    Warning: You are about to reset unity to its default configuration. 
       It is normal for your desktop to flicker during the process.    
    Type yes to continue, anything else to exit.        Do You wish to continue? _
    On rebooting all the log-in options' displays were correct and with intact Launchers and Panels.

    Running the same commands when logged into the faulty Ubuntu/Unity Blank Desktop gave a 'Can not open display' message and did nothing.

    It is probable - though I have not tried it - that the other compiz/unity reset commands would also work if run in the same way, from a desktop option that is working.

    See my Thread in Ubuntu+1 for even more suggested cures:

    Chao!, bogan.
    Last edited by bogan; May 27th, 2013 at 09:36 AM. Reason: corrrection
    "Better Solutions may bring Worsened Problems": After Lao Tse, b. circa 405BC. a contemporary of Confucius, who died circa 600BC.
    They did things differently in those days, apparently!!

  5. #25
    Join Date
    Oct 2006

    Re: Unity not loading after nvidia drivers installation

    Quote Originally Posted by wribeiro View Post
    type ccsm
    Enable Unity Plugin

  6. #26
    Join Date
    Aug 2011

    Re: Unity not loading after nvidia drivers installation

    I have this problem sometimes too. Usually, I load into another desktop enviroment (ie xfce, since it's lightweight), and for some reason, that ususally resolves it. Also try installing a different driver. That does it for me sometimes too.

Page 3 of 3 FirstFirst 123


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts