Results 1 to 3 of 3

Thread: GRUB refuses to load, shows "Error: File not found"

  1. #1
    Join Date
    Mar 2013

    Unhappy GRUB refuses to load, shows "Error: File not found"

    This is really agonizing for me. I was on Windows, when my battery ran out of power. It went into suspend mode, or tried to, but it sort of hanged there for well over 3 minutes, doing nothing. Suspend usually takes seconds. So I did a hard shut down, holding down the power button for a few. I rebooted and it shows the typical "GRUB Loading" screen, and hanged there. It did not change. Normally, it would only flash and then show me my OSes. I have a dual-boot of Windows 7 and Ubuntu 12..04. I tried booting into my Ubuntu Live CD and it would not load the desktop. Just goes blank screen on me. I am currently on my BackTrack 5R2 live USB. I tried re-installing GRUB through here and it reported "Installation completed successfully. No errors reported." I rebooted and I got a new error - "Error: File not found". It shows it on TWO lines, blanks out, and stays that way. I am very frustrated. I ran fdisk -l and it shows all of my partitions as normal. I tried grub-update and it acts like it isn't finding any operating systems. I don't understand.

  2. #2
    Join Date
    Nov 2008
    S.H.I.E.L.D. 6-1-6
    Ubuntu Development Release

    Re: GRUB refuses to load, shows "Error: File not found"

    Moved to absolute beginner section.

    Can you run the following on a livecd and post the output/files it generates (should be called output.txt)
    tar xvfz bootinfoscript-061.tar.gz
    sudo ./bootinfoscript output.txt
    Also, please see for a guide in reinstalling grub
    Don't waste your energy trying to change opinions ... Do your thing, and don't care if they like it.

  3. #3
    Join Date
    Mar 2013

    Re: GRUB refuses to load, shows "Error: File not found"

    I feel like a total idiot.

    All I had to do was boot from an Ubuntu live USB that was the same version as my dual-booted Ubuntu install (12.04). I then ran the same commands I tried in BackTrack and it worked. Looks like there IS a difference between the two, as far as the source of config files, and I didn't notice. For some reason, I kept feeling like I've done it from BT before. Oh well, guess not.

    I re-installed GRUB2 from there, rebooted, and it worked perfectly.

    In case anyone is wondering, here's the link:

    Oh, and thanks sandyd. I was going to address your request but my curiosity got the better of me. At least that led me to fixing it.

    Moral of the story: Don't overlook things. The solution might be simpler than you think.
    Last edited by ShadowByte; March 11th, 2013 at 03:38 PM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts