Results 1 to 4 of 4

Thread: Xchat broken packages

  1. #1
    Join Date
    Mar 2013
    Beans
    3

    Xchat broken packages

    I am new to ubuntu(or linux) and I don't have any idea about programming, but I am trying to learn about ubuntu, linux and programming and I thought that it will be really helpful if I have Xchat by my side. But after updating a while ago, my Xchat was uninstalled(i don't know why and how) and when I was trying to reinstall it, software manager said that I have a broken package. I also tried installing it from terminal but it said





    Code:
    Some packages could not be installed. This may mean that you haverequested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    
    The following packages have unmet dependencies:
     xchat : Depends: libperl5.12 (>= 5.12.4) but it is not installable
    E: Unable to correct problems, you have held broken packages.

  2. #2
    ibjsb4 is offline Ubuntu addict and loving it
    Join Date
    Sep 2012
    Beans
    4,996

    Re: Xchat broken packages

    Try

    Code:
    sudo dpkg --configure -a
    
    sudo apt-get -f install

  3. #3
    Join Date
    Mar 2013
    Beans
    3

    Re: Xchat broken packages

    tried it.here's what is said.

    Code:
    Reading package lists... DoneBuilding dependency tree       
    Reading state information... Done
    The following package was automatically installed and is no longer required:
      xchat-common
    Use 'apt-get autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
    explorer@linuxnoob:~$ sudo apt-get autoremove
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages will be REMOVED:
      xchat-common
    0 upgraded, 0 newly installed, 1 to remove and 4 not upgraded.
    After this operation, 3,408 kB disk space will be freed.
    Do you want to continue [Y/n]? y
    (Reading database ... 173653 files and directories currently installed.)
    Removing xchat-common ...
    Processing triggers for gconf2 ...

    after that, i tried installing xchat again but here's what it said again

    Code:
    explorer@linuxnoob:~$ sudo apt-get install xchatReading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    
    The following packages have unmet dependencies:
     xchat : Depends: libperl5.12 (>= 5.12.4) but it is not installable
    E: Unable to correct problems, you have held broken packages.

  4. #4
    ibjsb4 is offline Ubuntu addict and loving it
    Join Date
    Sep 2012
    Beans
    4,996

    Re: Xchat broken packages

    What version are you running? In terminal:

    Code:
    cat /etc/issue

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •