Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: I cannot login to tty after fresh install

  1. #1
    Join Date
    Mar 2013
    Beans
    37

    I cannot login to tty after fresh install

    hello

    after a fresh xubuntu (quetzal) inlstall , i wanted to install the nvidia drivers
    but i cannot login to tty1 with my regular login name
    lthough it works in xfce terminal emulator (with sudo for instance)

    pls help ...

  2. #2
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    12,624
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: I cannot login to tty after fresh install

    rompelstilchen; Hi ! Welcome to the forum .

    It is unclear to me the nature of your problem. Do you mean that the key combo ctl+alt+f1 does not yield tty1 console, or once to tty1 your username and/or password is not accepted ? What are you attempting to do and what steps are you taking to attempt to do so ?
    try'n to help

  3. #3
    Join Date
    Jun 2008
    Location
    South Africa
    Beans
    39
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: I cannot login to tty after fresh install

    What username are you trying to log in with? Best way to check that you are logging in with the correct username is in your UI session open the terminal and type the command
    Code:
    whoami
    then make sure you are trying to login with whatever whoami returns.
    Last edited by solarghost; March 12th, 2013 at 03:18 PM. Reason: Trying the code tags

  4. #4
    Join Date
    Mar 2013
    Beans
    37

    Re: I cannot login to tty after fresh install

    i go to the tty1 with alt+ctrl+F1
    and i use my regular user (the one who works with sudo)
    so i use my user name/my password
    the only user i created at install time

  5. #5
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: I cannot login to tty after fresh install

    Do you have some special characters in your user name or your password, I mean some character with a higher ascii number than 127?

  6. #6
    Join Date
    Mar 2013
    Beans
    37

    Re: I cannot login to tty after fresh install

    well it says that i am logged with the user i created at intall time
    so i guess that user is created for x sessions, not for tty sessions, but i dont know how to achieve this, and if it is a good idea(security reasons)

    the plan is to install nvidia drivers for an old geforce 4200

    i found the drivers, but it requires to be done with no x running
    so i guess i would have to turn off lightdm too

    but i need to be able to login in tty1/2/3...

  7. #7
    Join Date
    Mar 2013
    Beans
    37

    Re: I cannot login to tty after fresh install

    nop 4 regular letters

  8. #8
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: I cannot login to tty after fresh install

    - Do you get the prompt to log in after ctrl + alt + F1 ?

    - What is written, after you enter your user name?

    - What is written, after you enter your password? There is no output while you type your password, just finish with the ENTER key.

  9. #9
    Join Date
    Mar 2013
    Beans
    37

    Re: I cannot login to tty after fresh install

    look i have used termi,nals for years, i just put my question in the beginner question cos it is an easy first attemp question
    i installed xubuntu (and on the xubuntu web page, i got redirected here)

    so it is like



    login : i type my 4 letters login then enter]
    password : i type my password [enter]

    wrong login and password

    login :

  10. #10
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: I cannot login to tty after fresh install

    I see that you know what to do. And I have to admit that I don't understand what is happening.

    There is something wrong, your system should allow this.

    1. Do you use some special locale (national keyboard setting), that would be different between the graphical user interface and the text screen?

    2. Try to log in via the recovery mode at the grub menu.

    3. Maybe you can try this work-around: (If you need, you can restore it when booted from the Xubuntu install drive.)

    Backup these two files (to be restored if necessary).

    Code:
    sudo cp -p /etc/default/grub /etc/default/grub.sav
    sudo cp -p /boot/grub/grub.cfg /boot/grub/grub.cfg.sav
    edit your /etc/default/grub file. Change the line

    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    to
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash text"
    (save the file) and run
    Code:
    sudo update-grub
    and reboot. Now you should arrive directly at a text screen. I hope you can log in.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •