Results 1 to 3 of 3

Thread: Still booting to Windows

  1. #1
    Join Date
    Jun 2008
    Location
    USA
    Beans
    117
    Distro
    Ubuntu 13.04 Raring Ringtail

    Still booting to Windows

    Hey guys, I'm sure this has come up a thousand times, but I could use a little quick help.

    So last night I re-installed windows on my second HDD (500Gb) so I could play some games with friends. My first HDD had Ubuntu 12.04 on it and planned on doing a clean install of 12.10 today. I thought everything would go fine since I installed Windows first and then GRUB would allow me to choose what OS to boot to after I installed 12.10. Well I guess that's not the case.

    So now I have the first HDD as this:

    /root - 25Gb
    /swap - 4Gb
    /home - rest of the drive

    2nd HDD:

    Windows

    I chose the first HDD as the place to install the bootloader or whatever for Ubuntu 12.10. Should I have picked the windows drive? Is there any way to fix this or do I have to re-install Ubuntu 12.10 again?

    Any help would be greatly appreciated!
    Last edited by tmette; March 10th, 2013 at 09:23 PM.

  2. #2
    Join Date
    Nov 2009
    Location
    Mataro, Spain
    Beans
    13,729
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Still booting to Windows

    It seems 12.10 doesn't install grub2 correctly on the MBR sometimes. Boot the ubuntu cd/dvd in live mode, and if the root partition is /dev/sda1 as you mentioned, in terminal try:
    Code:
    sudo mount /dev/sda1 /mnt
    sudo grub-install --root-directory=/mnt /dev/sda
    Also don't forget to set BIOS to boot from sda. Restart and see how it goes.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 14.04 LTS 64bit & Windows 10 Pro 64bit

  3. #3
    Join Date
    Jun 2008
    Location
    USA
    Beans
    117
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Still booting to Windows

    Thanks, I'll give that a try. I should mention that when I installed Windows, I had the first HDD unplugged. So I will check the boot order in my BIOS, maybe it got switched?

    EDIT: Thanks, darkod! I guess the BIOS setting of my HDD boot priority got switched since I didn't have the master drive plugged in. I just changed it back to boot to the master drive first and GRUB came up as normal.
    Last edited by tmette; March 10th, 2013 at 09:18 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •