Results 1 to 10 of 15

Thread: Wifi problems: Asus x401a, ra5390, rt2800pci

Threaded View

  1. #1
    Join Date
    Apr 2007
    Beans
    47

    Wifi problems: Asus x401a, ra5390, rt2800pci

    I need help with my wireless connection after my new install of Mint 14 64bit.

    Here's my set up:
    Asus x401a
    Mint 14-64 updated
    Ralink 5390
    driver rt2800pci
    positioned < 8 ft from router

    Symptoms:
    1. sees my router and neighbors
    2. sees my router after startup at 72%, hp next to it shows 98%
    3. tries to autoconnect, fails, asks for password, fails, etc. - may repeat endlessly
    4. occasionally connects - loads slowly, shows 65% power, then 42%, then 25%, begins to ask for password again, endless repeat
    5. hp laptop next to Asus is stable & downloading quickly on same router
    6. wired connection is stable
    7. no other problems with the install so far

    What I've tried:
    1. double checked password
    2. rebooted router
    3. tried 32bit live cd Mint 14
    4. tried suggestions from "Ralink 5390 / Compaq persario..." in Networking & Wireless forum to download & install rt2860 driver, that gave better power readings but goes into kernel panic under load - clean re-install afterwards
    5. tried OpenSuse 64 which gave higher power readings and more stability, but cuts out at more than 12 ft from router

    Using commands from other threads my output is:

    bill@Liveoak ~ $ lspci -nn | grep 0280
    02:00.0 Network controller [0280]: Ralink corp. RT5390 Wireless 802.11n 1T/1R PCIe [1814:5390]

    bill@Liveoak ~ $ lsmod | grep rt2
    rt2800pci 18528 0
    rt2800lib 58685 1 rt2800pci
    crc_ccitt 12667 1 rt2800lib
    rt2x00pci 14475 1 rt2800pci
    rt2x00lib 54891 3 rt2800pci,rt2800lib,rt2x00pci
    mac80211 539908 3 rt2800lib,rt2x00pci,rt2x00lib
    cfg80211 206566 2 rt2x00lib,mac80211
    eeprom_93cx6 13302 1 rt2800pci

    I'm a regular Linux user, but don't know how to work under the hood. It's more 'monkey see, monkey do'.

    Thanks for your help.
    Last edited by BeardedOne; March 9th, 2013 at 10:02 PM. Reason: mark it solved
    If this was only a movie, I could re-write the ending.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •