Results 1 to 3 of 3

Thread: Boot-repair didn't help on Lenovo Z580 "error: unknown filesystem"

  1. #1
    Join Date
    Mar 2013

    Boot-repair didn't help on Lenovo Z580 "error: unknown filesystem"

    Hi all,

    Hope you can help.

    I have windows 8 on one partition, and had an ubuntu installation that I managed to break by upgrading the nvidia drivers on another. I decided I'd give linux mint a try and when this installed grub borked out with "error: unknown filesystem" . I've tried boot repair (twice now) and I still get the same problem when I boot.

    Any help much appreciated.



  2. #2
    Join Date
    Mar 2013

    Re: Boot-repair didn't help on Lenovo Z580 "error: unknown filesystem"

    I may be OK now, I followed the instructions here, this got me my grub menu back. Mint would only boot every now and again (if I entered the BIOS and out again, then it would boot). I then ran boot-repair again, and it (fingers-crossed!) seems to boot OK now into windows and mint.

    I'll come back if I continue to have problems with the intermittent boot.

  3. #3
    Join Date
    Jun 2009
    SW Forida
    Ubuntu 16.04 Xenial Xerus

    Re: Boot-repair didn't help on Lenovo Z580 "error: unknown filesystem"

    You have Windows 8 installed in UEFI mode with gpt partitioning.

    But you show a grub installed to the gpt drive's protective MBR. You can boot gpt drives in BIOS mode with Ubuntu, but it makes dual booting Windows in UEFI mode very difficult as you have to go back into UEFI and turn it on or off to boot Linux in BIOS mode.

    Best to have Linux in UEFI mode. And Ubuntu is one of the few that will work with secure boot versions of Windows. With secure boot off then other Linux may also work.

    Boot-Repair will convert a BIOS install of Ubuntu to UEFI by uninstalling grub-pc (BIOS) and installing grub-efi (UEFI) if drive is gpt.
    How Boot-Repair fixes a Ubuntu with grub-pc with efi Windows
    Boot-Repair - Updated Jan 1, 2013 to not rename first time, but rename if first time Windows does not boot. Post 706 and 711
    Boot-Repair copied /EFI/ubuntu/grubx64.efi to /EFI/Boot/bootx64.efi (in case the BIOS is hard-coded to boot into /EFI/Boot/bootx64.efi or secure boot
    signed GRUB file shimx64.efi.
    For more info on UEFI boot install & repair - Regularly Updated :
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts