I recently got one of these devices and unfortunately it does not seem to be auto-detected on my 12.04 system (using Gnome 3) for Mobile Broadband use, but after a lot of research I finally got it working.

For anyone else who has a similar issue, here are the steps I used to get it going:

  1. Plug the device into your USB port, give it 10 seconds or so to settle and then run this in a terminal:
  2. Find the line that looks similar to this and note the "ID" data:
    Bus 002 Device 005: ID 12d1:140c Huawei Technologies Co., Ltd.
  3. Download and install the sakis3g tool:

  4. Do this to create a default configuration file:
    sudo gedit /etc/sakis3g.conf
  5. Paste the following into this file, modify it for your ISP and USB ID device settings and then save it:
    CUSTOM_APN="your custom APN"
    APN_USER="your user name"
    APN_PASS="your password"
  6. Run the saskis3g program (from where-ever you downloaded it to) and choose the "Connect" selection.
  7. You should now have a 3G connection!
  8. Use the option to create a Desktop Shortcut to launch it.

I got this working on the Exetel ISP in Australia using an Optus USB modem - as they are just resellers of this network.

Please note that using this sakis3g script will disable any DNS settings on other network connections when you disconnect from the 3G service. Simply disable and re-enable networking to fix things back up.