Results 1 to 10 of 14

Thread: Ethernet port not registering

Threaded View

  1. #1
    Join Date
    Oct 2010
    Lubuntu 13.04 Raring Ringtail

    Ethernet port not registering

    I just got a new laptop. The ethernet port worked in Windows before I installed Ubuntu (no longer have Windows installed) but it's not working in Ubuntu. ifconfig returns nothing for ethernet, only lo and usb0 (I'm connected to Internet via USB tether to my phone). lspci -v returns the following:

    03:00.0 Ethernet controller: Atheros Communications Inc. AR8161 Gigabit Ethernet (rev 10)
    Subsystem: ASUSTeK Computer Inc. Device 14c7
    Flags: bus master, fast devsel, latency 0, IRQ 10
    Memory at f7c00000 (64-bit, non-prefetchable) [size=256K]
    I/O ports at e000 [size=128]
    Capabilities: [40] Power Management version 3
    Capabilities: [58] Express Endpoint, MSI 00
    Capabilities: [c0] MSI: Enable- Count=1/16 Maskable+ 64bit+
    Capabilities: [d8] MSI-X: Enable- Count=16 Masked-
    Capabilities: [100] Advanced Error Reporting
    Capabilities: [180] Device Serial Number ff-93-03-a3-08-60-6e-ff

    My modem is on and connection to my computer and I tried two ethernet cables. I'm thinking it might be an issue in the BIOS but I couldn't find anything to enable ethernet when I looked around the BIOS. Or perhaps I need an update, because that was the solution to someone else's similar problem. (They had to download and install driver r8168-8.028.00)

    Last edited by ShadowVegan; March 4th, 2013 at 05:19 PM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts