Results 1 to 2 of 2

Thread: Logitech Performance MX and M570 Mice recievers not recognized.

  1. #1
    Join Date
    Mar 2013
    Beans
    1

    Logitech Performance MX and M570 Mice recievers not recognized.

    I have searched and found many threads about this issue but none were answered or had my specific question.

    I have the Logitech Performance MX and M570 Mice. The recievers are not being recognized and the drivers are not downloading. I can't seem to find any driver downloads for them and this issue is begining to bug me.
    Any advice you are willing to give would be helpful.

    Ubuntu 12.10.

  2. #2
    Join Date
    May 2011
    Location
    Kaiserslautern, DE
    Beans
    3
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Logitech Performance MX and M570 Mice recievers not recognized.

    I bought that exact mouse today actually, the M570... I am using 12.10 as well... when I first plugged it in it did not respond at all, I didn't install any drivers, I checked lsusb in terminal and saw logitech showed up in the usb... after plugging it in and turning it on and off it just worked on it's own... I'm sorry I can't give any specific instructions, but I should also add after it started working I shut down my computer for awhile, tunred it back on and the mouse wasn't responding again, I took the usb reciever out and plugged it back in and it started working fine again... I didn't install any drivers at all if I didn't already mention that...

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •