Results 1 to 9 of 9

Thread: After BIOS reset to default settings grub is gone....

  1. #1
    Join Date
    Apr 2012
    Beans
    40
    Distro
    Ubuntu 13.04 Raring Ringtail

    After BIOS reset to default settings grub is gone....

    Hi all

    i have (had) a dual boot ubuntu-Win8 on UEFI and i also have Mageia on another partition. Everything was working fine, Grub was able to run Ubuntu - Win 8 and Mageia without problem but after a BIOS reset to default settings Grub seems gone and on startup i only have Mageia boot loader (this load fine) but _Ubuntu is gone and Win8 doesn't load.

    I've used a LiveUSB of secureUBuntu and run boot repair few times with no luck

    my bios now is set with Boot mode as LEgacy Support and Boot priority as Legacy First

    Changing to Boot mode as LEgacy Support and Boot priority as UEFI first doesn't help

    here last boot repair

    http://paste.ubuntu.com/5582077/

    Help Please!!!
    Last edited by sushi80; March 3rd, 2013 at 07:51 PM.

  2. #2
    Join Date
    Jul 2011
    Location
    South-Africa
    Beans
    678
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: After BIOS reset to default settings grub is gone....

    Hay

    This is simply a drive sequence issue. Usualy F11/12 during boot will bring up a "boot device selection screen". Try selecting a different drive untill your grub prompt pops up.
    Then set your first boot device to this drive.

    Good luck
    Last edited by zero2xiii; March 3rd, 2013 at 03:49 PM. Reason: Oops :$
    Switched away from windows XP to Ubuntu 9.04. Never turned around to look back.

  3. #3
    Join Date
    Apr 2012
    Beans
    40
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: After BIOS reset to default settings grub is gone....

    Unfortunately is not that easy....i can only choose between "ubuntu" "Ata HDD" "CD" and "Network"

    if i select "ubuntu" i get the grub from Mageia
    if i select "ATA HDD" i get again the grub from Mageia

    it seems that the EFI menu from ubuntu is gone....

  4. #4
    Join Date
    Jul 2011
    Location
    South-Africa
    Beans
    678
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: After BIOS reset to default settings grub is gone....

    Hay,Well grub's menu seems fine from the pastebin post.What are your grub options? Can you get to a grub terminal and manually mount and boot the OS?Refer to the following links for details on how to accomplish this tedious task:
    http://forums.justlinux.com/showthre...Linux-manually
    http://tuxers.com/main/instigating-a...e-grub-prompt/
    http://www.novell.com/communities/no...sing-grub-sles

    Possibly try chainloading your grub from Mageia, the above links cover that as well in some form.
    Good luck
    Last edited by zero2xiii; March 3rd, 2013 at 05:54 PM. Reason: Damn new software skrewing around the links....
    Switched away from windows XP to Ubuntu 9.04. Never turned around to look back.

  5. #5
    Join Date
    Apr 2012
    Beans
    40
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: After BIOS reset to default settings grub is gone....

    it seems like the EFI partition is skipped at boot.... for my understanding the Ubuntu grub should be there....

    the grub loaded from mageia has 3 options

    boot mageia --- works
    boot mageia (safe mode) ---works
    boot windows ----- broken

  6. #6
    Join Date
    Jul 2011
    Location
    South-Africa
    Beans
    678
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: After BIOS reset to default settings grub is gone....

    Yes,

    So that is a problem. But try and boot ubuntu from the grub you get at the moment. There might be a whole different reason (such as time out) which causes that grub not to come up, but you must first try and make sure that ubuntu is still bootable.

    Switched away from windows XP to Ubuntu 9.04. Never turned around to look back.

  7. #7
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: After BIOS reset to default settings grub is gone....

    You have grub legacy (Mageia?) in MBR. So if you are booting that, you are booting in BIOS mode not UEFI mode. You still show ubuntu & Windows in efi partition so if you boot in UEFI mode you should see those. But BIOS mode installs are not compatible with UEFI mode installs so you cannot easily dual boot Mageia and Ubuntu. UEFI and BIOS write system info somewhat differently, so you have to go back into UEFI/BIOS and turn on or off to boot in system installed in that mode. Since Mageia seems to be using grub legacy, it may have even have a efi boot capability and only a few Linux will boot with secure boot systems.
    So turn off legacy/BIOS boot, turn on UEFI boot but do not turn on secure boot. Some system do not make it clear on UEFI settings, so you have to figure out how yours works.

    Under Windows 8 Secure Boot, all PCs, no matter what operating system they actually run, must include several Microsoft-owned keys.
    The State Of Linux Distributions Handling Secure Boot
    http://www.phoronix.com/scan.php?pag...tem&px=MTI2MzI
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  8. #8
    Join Date
    Apr 2012
    Beans
    40
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: After BIOS reset to default settings grub is gone....

    I was able to recover my system using gparted, i run a check of EFI partition and at the end i finally got again ubuntu Grub

    the only problem is that during many test i've done i've also re-installed ubuntu

    anyway now grub can load Ubuntu - Win8 and Megeia (using 30_os-prober)

  9. #9
    Join Date
    Jul 2011
    Location
    South-Africa
    Beans
    678
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: After BIOS reset to default settings grub is gone....

    Glad to hear

    Please mark thread as solved then...
    Switched away from windows XP to Ubuntu 9.04. Never turned around to look back.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •