Results 1 to 3 of 3

Thread: Tried Installing ATI Video Drivers, Now nothing works -_-

  1. #1
    Join Date
    Feb 2013

    Tried Installing ATI Video Drivers, Now nothing works -_-

    After getting annoyed with Ubuntu's "Unity Dash Home" being very laggy, even after getting compiz and making edits, I had decided to try to get the official ATI Video Card Drivers working (AMD if you really must). I also intend to play game on my Ubuntu Install as I have steam So I'm fairly certain that this would be recommend anyways. So I installed "Additional Drivers" (the software item from the software centre), and got a bit confused by it told it to cancel at 20% although for some reason it did something anyways, where as on most well programmed applications it would revert what it did, making we wonder why the cancel button even exist if it can't be used.

    So now when I boot up and log in, I see my desktop icons. Unity Bar does not load and "XScreenSavers" Freaks out with errors when I leave my PC to long. Basically nothing works. I tried unity --reset in terminal and stuff and what not but nothing works.

    What should I do
    Last edited by Inject; March 4th, 2013 at 01:40 AM.

  2. #2
    Join Date
    May 2007
    Virginia, USA
    Ubuntu Mate Development Release

    Re: Tried Installing ATI Video Drivers, Now nothing works -_-

    You will need to remove the drivers and reinstall the default Radeon open-source drivers. Instructions are in the link below:

    And for future reference, it is really a BAD idea to cancel something part way through. Better to let it complete and then just remove or uninstall it.
    Ubuntu 17.04 Mate, Mint 18.1 Mate; MS Win 8.1, MS Win10 Pro.
    Will not respond to PM requests for support -- use the forums.

  3. #3
    Join Date
    Feb 2013

    Re: Tried Installing ATI Video Drivers, Now nothing works -_-

    OK, thank you very much. That worked well I used the following command from that wiki to fix it:
    sudo apt-get remove --purge xorg-driver-fglrx fglrx* sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core sudo dpkg-reconfigure xserver-xorg
    XScreenSavers appears to not work now for some reason, perhaps I'll have to reinstall that? Not really sure why though.

    New Issue has arose however,
    I got my Unity bar back and all that fun stuff. However, after that I went into software sources - additional drivers - and then applied the proprietary drivers for ATI, it broke everything again.

    What am I doing wrong?

    How Can I get the Offical ATI/AMD Video Drivers for Radeon HD 5870 working? I plan to game on this so I'm sure I'd need them.
    I've followed wiki's on this nothing appears to work.

    If you can help that would epic
    Thanks :/
    Last edited by Inject; March 4th, 2013 at 01:43 AM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts