Results 1 to 4 of 4

Thread: 9.04 installation hangs on remove_broken_cdrom

  1. #1
    Join Date
    Aug 2009

    Post 9.04 installation hangs on remove_broken_cdrom

    I am installing Ubuntu 9.04 desktop alternate from the image ubuntu-9.04-alternate-amd64.iso.
    I am using alternate in order to have embedded RAID support.

    The installation hangs at the end, (finishing the installation is the screen title)
    with the progress bar at 4% and the text "Running remove_broken_cdrom..."
    at the bottom left of the progress window.
    I run a CD check (passed OK) and tried again a complete install, same hanging behaviour.

    Any hints of what is happening, or what should I do to solve this?

    I found a way out. Don't know if it is 100% OK.
    Forced the reboot with the hardware reset button. Selected the recovery option from the CD startup menu. Asked to reinstall grub, and specified (hd0,0) as root for booting.
    Then rebooted almost successfully, but the master user defined in the original install process was not there. So rebooted again in single mode, added the user, made him part of admin group, modified sudoers adding
    %admin ALL=(ALL) ALL
    as usual in Ubuntu configurations, and finally rebooted correctly
    However I have not yet really tested the installed packages, it boots with Xwindows and allows me to login with the master user.

    See below the detailed configuration of the system

    The PC has a quad-core, and 4 SATA HD, 500 GB. The first 3 HD are going to be used in various RAID configurations. The 4th is on its own.
    Partitions are
    sda1 2 GB primary bootable - for RAID1 (will be /boot)
    sda2 6 GB primary - for RAID5 (will be SWAP)
    sda3 80 GB primary - for RAID5 (will be /var/log)
    sda4 452.1 GB primary - for RAID5 (will be /)
    and same pattern for sdb and sdc

    sdd1 400 GB primary /tlc
    sdd2 100.1 GB unused

    The RAID config is
    md0 = sda1+sdb1 RAID1 /boot
    md1 = sda2+sdb2+sdc2 RAID5 = 12 GB SWAP
    md2 = sda3+sdb3+sdc3 RAID5 = 80 GB /var/log
    md3 = sda4+sdb4+sdc4 RAID5 = 904.2 GB /
    sdc1 remain unused

    the /boot partition is on RAID1 instead of RAID5 because apparently
    RAID5 is not supported for the boot
    In the past (ubuntu 8.04) I successfully built PCs with boot from RAID1
    I tried with a RAID5, no success. If anyone has hints about booting from
    RAID5 I will be happy to know.

    I SOLVED the situation as follows:
    booted again from the install CD ane selected recovery broken system
    then reinstall grub specifying (hd0,0) as root for booting
    Next time it will boot, but the install process maybe did not complete and did not create
    the main user. In that case, boot again and from grub menu choose single mode.
    Now you are root and you can create the user you like as part of admin group"
    adduser mypreferredname admin
    and finally to comply with ubuntu safety policy use visudo to add in sudoers the line
    %admin ALL=(ALL) ALL
    then you can reboot and use the system with the user you created.
    In order to be sure that the system can boot in any of the two bootable disks, when the other is
    damaged, you have to install grub on both disks:
    at boot startup in console mode and give the command
    grub> find /grub/stage1
    you get the list of HD where ti can be installed, typically:
    (hd0), (hd1)
    now install grub on MBR of both disks:
    grub> root (hd0,0)
    grub> setup (hd0)
    grub> root (hd1,0)
    grub> setup (hd1)
    Last edited by spin_srl; August 28th, 2009 at 11:47 AM. Reason: added more information with the solution

  2. #2
    Join Date
    Aug 2009

    Re: 9.04 installation hangs on remove_broken_cdrom

    Have the same problem... but no special configuration in my case , only default options and automatic disk configuration.... image is ubuntu-9.04-server-i386.iso,
    HDD is 750 GB SATA Seagate and CDROM is IDE, model Optiarc DVD RW AD-7173A

    UPD: Switching CD-drive solved the problem
    Last edited by gospodin.horoshiy; August 28th, 2009 at 11:37 AM.

  3. #3
    Join Date
    Jan 2010

    Re: 9.04 installation hangs on remove_broken_cdrom


    I think I solved this problem in a somewhat simpler way. I used a pin to manually eject my CD-ROM and then the installer continued on its merry way.


  4. #4
    Join Date
    Mar 2013

    Re: 9.04 installation hangs on remove_broken_cdrom

    Try the following when the "remove_broken_cdrom" message appears:

    ALT+F2 to switch to a new console, then ENTER to activate it
    Type the command: killall vol_id
    ALT+F1 to switch back to the installer

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts