Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 31

Thread: Tilda key not working in terminal only

  1. #11
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: Tilda key not working in terminal only

    Quote Originally Posted by tliimfee View Post
    F12 doesn't display any character.
    I don't have any stty commands in .profile or .bashrc
    And the commands
    Code:
    reset; stty sane; clear
    didn't fix the problem.
    I don't know why this is happening.

    - Did the tilde key work in the terminal before?

    - What terminal program are you running? Check at

    Help -- About

    - Does tilde work in a text screen, that you get pressing the hotkey combination
    ctrl + alt + F1

    - What shell are you running (bash, or some other shell)? Check with
    Code:
    echo $SHELL
    - What happens if you paste a tilde character into a terminal window? Will it be displayed or not? Will it work as an alias for $HOME?

    - Have you created a hotkey, that intercepts tilde?

    - Will it work in your computer with another OS (Windows, Ubuntu booted from the install CD, or is your computer an Apple product)?

  2. #12
    Join Date
    Feb 2011
    Beans
    15

    Re: Tilda key not working in terminal only

    The tilde key did work before in terminal, it just doesn't now.
    Help returns:
    Code:
    GNOME Terminal
    3.4.1.1
    With Ctrl+alt+F1 tilde does not work when I am logged into the terminal, however it does work if I am trying to use ~ in the user name.

    Code:
    echo $SHELL
    returns
    Code:
    /bin/bash
    If I paste ~ into the terminal it is not shown and doesn't take up a character space.
    $HOME works but I don't know if ~ is working correctly because I can never execute it.

    I'm dual booting with windows 7 and the ~ button works fine in that. It seems to just not be working in the terminal in Ubuntu.

  3. #13
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: Tilda key not working in terminal only

    So it seems that ~ is not working for you in bash, but works at your login (and in programs).

    What happens when you boot your computer from your Ubuntu install CD/USB drive? I guess it works there.

    I think that some installed program is intercepting ~ for you. Can you think of any program that you have installed recently (or at the time when you lost ~)? Or have you installed or changed a hotkey?

  4. #14
    Join Date
    Feb 2011
    Beans
    15

    Re: Tilda key not working in terminal only

    It works from a boot disk, and I've tried re-installing gnome-terminal and using konsole but the problem is still there.
    The only changes I think I've made have to do with the terminal color pallet, vim plugins and adding a new font.
    I'm not sure how any of them could have done this.

    Is there a way I can find which process is listening for/grabbing the key action?

  5. #15
    Join Date
    May 2010
    Location
    uk
    Beans
    9,324
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Tilda key not working in terminal only

    Hi

    Do you get the same behaviour in xterm ?

    Kind regards
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

    Thinking about becoming an Ubuntu Member?

  6. #16
    Join Date
    Feb 2011
    Beans
    15

    Re: Tilda key not working in terminal only

    Yes I get the same behavior in xterm.

  7. #17
    Join Date
    May 2010
    Location
    uk
    Beans
    9,324
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Tilda key not working in terminal only

    Hi

    Can you post all your bash config files please.

    Kind regards
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

    Thinking about becoming an Ubuntu Member?

  8. #18
    Join Date
    Feb 2013
    Beans
    Hidden!

    Re: Tilda key not working in terminal only

    Does it work in /bin/dash? Enter dash from a terminal with
    Code:
    sh
    Exit from it with Ctrl+d or
    Code:
    exit

  9. #19
    Join Date
    Feb 2011
    Beans
    15

    Re: Tilda key not working in terminal only

    The ~ does work inside dash.

    My bash config file is:
    Code:
    # ~/.bashrc: executed by bash(1) for non-login shells.
    # see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
    # for examples
    
    # If not running interactively, don't do anything
    [ -z "$PS1" ] && return
    
    # don't put duplicate lines or lines starting with space in the history.
    # See bash(1) for more options
    HISTCONTROL=ignoreboth
    
    # append to the history file, don't overwrite it
    shopt -s histappend
    
    # for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
    HISTSIZE=1000
    HISTFILESIZE=2000
    
    # check the window size after each command and, if necessary,
    # update the values of LINES and COLUMNS.
    shopt -s checkwinsize
    
    # If set, the pattern "**" used in a pathname expansion context will
    # match all files and zero or more directories and subdirectories.
    #shopt -s globstar
    
    # make less more friendly for non-text input files, see lesspipe(1)
    [ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"
    
    # set variable identifying the chroot you work in (used in the prompt below)
    if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
        debian_chroot=$(cat /etc/debian_chroot)
    fi
    
    # set a fancy prompt (non-color, unless we know we "want" color)
    case "$TERM" in
        xterm-color) color_prompt=yes;;
    esac
    
    # uncomment for a colored prompt, if the terminal has the capability; turned
    # off by default to not distract the user: the focus in a terminal window
    # should be on the output of commands, not on the prompt
    #force_color_prompt=yes
    
    if [ -n "$force_color_prompt" ]; then
        if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
    	# We have color support; assume it's compliant with Ecma-48
    	# (ISO/IEC-6429). (Lack of such support is extremely rare, and such
    	# a case would tend to support setf rather than setaf.)
    	color_prompt=yes
        else
    	color_prompt=
        fi
    fi
    
    if [ "$color_prompt" = yes ]; then
        PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
    else
        PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
    fi
    unset color_prompt force_color_prompt
    
    # If this is an xterm set the title to user@host:dir
    case "$TERM" in
    xterm*|rxvt*)
        PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
        ;;
    *)
        ;;
    esac
    
    # enable color support of ls and also add handy aliases
    if [ -x /usr/bin/dircolors ]; then
        test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
        alias ls='ls --color=auto'
        #alias dir='dir --color=auto'
        #alias vdir='vdir --color=auto'
    
        alias grep='grep --color=auto'
        alias fgrep='fgrep --color=auto'
        alias egrep='egrep --color=auto'
    fi
    
    # some more ls aliases
    alias ll='ls -alF'
    alias la='ls -A'
    alias l='ls -CF'
    
    # Add an "alert" alias for long running commands.  Use like so:
    #   sleep 10; alert
    alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'
    
    # Alias definitions.
    # You may want to put all your additions into a separate file like
    # ~/.bash_aliases, instead of adding them here directly.
    # See /usr/share/doc/bash-doc/examples in the bash-doc package.
    
    if [ -f ~/.bash_aliases ]; then
        . ~/.bash_aliases
    fi
    
    # enable programmable completion features (you don't need to enable
    # this, if it's already enabled in /etc/bash.bashrc and /etc/profile
    # sources /etc/bash.bashrc).
    if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
        . /etc/bash_completion
    fi

  10. #20
    Join Date
    May 2010
    Location
    uk
    Beans
    9,324
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Tilda key not working in terminal only

    Hi

    Can you also post

    /etc/bash.bashrc and ~/.bash_aliases and /etc/bash_completion

    I may be wrong but this does look like a bash problem.

    Kind regards
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

    Thinking about becoming an Ubuntu Member?

Page 2 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •