Results 1 to 10 of 22

Thread: Webcam Issues

Threaded View

  1. #1
    Join Date
    Feb 2013

    Webcam problems on Lemu4 after kernel update

    After a recent ubuntu update, I no longer had webcam functionality. I reinstalled 12.10 via a live disk and tested the webcam with cheese--it worked fine. It only stops working after fully updating.

    The restore settings feature via the System76 driver did not fix the problem.
    Resetting things to "Optimized Defaults" in the bios didn't help either.

    This could be a number of things (gstreamer?, kernel patch?). I will look at the packages installed in the update

    Model: Lemu4, Ubuntu 12.10

    UPDATE: Device is still listed under ls /dev/video* as video0
    lsusb still displays the device
    In the preferences menu of cheese the device is still recognized but no image is displayed.
    Testing the pipeline in gstreamer-properties yields no display of output, only says "testing pipeline"
    kamerka doesn’t display anything either.

    I think the problem is coming from linux-headers-generic

    UPDATE 2: Running the System Testing program's camera test shows that it doesn't work.
    Results for picture test: Image viewer opened and said "Could not load image 'camera_test_lm810p.jpg'. Error interpreting JPEG image file (Improper call to JPEG library in state 200)"
    Nothing showed up at all during the video test.

    UPDATE 3: Forced linux-image-generic and linux-headers-generic to earlier version with Synaptic - Still no success.
    Reset cheese's config with dconf editor - Unsuccessful

    I'm running out of ideas :S

    Update 4: Similar to cashat, guvcview works and skype does not. I also filed a system76 support case and have yet to receive a reply.

    Update 5: Forgot to mention earlier that fn+f10 does turns the camera on or off but image/video is still not displayed.

    Could these certain programs have incompatibilities with kernel updates rather than this being a kernel fault? Perhaps an ffmpeg library or something to do with gstreamer prevents these programs from working correctly with a new kernel? I know cheese is fairly unreliable but the null result from gstreamer-properties is suspicious.
    Attached Files Attached Files
    Last edited by jedsled; February 25th, 2013 at 05:31 AM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts