Results 1 to 3 of 3

Thread: gfortran dependency hell

  1. #1
    Join Date
    Oct 2005

    gfortran dependency hell

    I was trying to install an R package which said it couldn't find -lgortran. So I uninstalled gfortran. However, when I tried to install it again, I got the following error

    gfortran : Depends: gfortran-4.7 (>= 4.7.2-1~) but it is not going to be installed
    When I tried installing gfortran-4.7

    gfortran-4.7 : Depends: gcc-4.7-base (= 4.7.2-2ubuntu1) but 4.7.2-11precise2 is to be installed
                 Depends: gcc-4.7 (= 4.7.2-2ubuntu1) but 4.7.2-11precise2 is to be installed
    When I try installing gcc-4.7-base or gcc-4.7, it tells me they're already installed.

    What's happening here and how can I fix this?

    I'm running 12.10


  2. #2
    Join Date
    Apr 2012

    Re: gfortran dependency hell

    It could be happen if you try to instal a package from source. This hell of dependency always solved on my machine by installing from repo, with using Synaptic Package Manager.

  3. #3
    iMac71 is offline Gee! These Aren't Roasted!
    Join Date
    Dec 2012

    Re: gfortran dependency hell

    you might proceed as follows: open a Terminal window and type in sequence:
    gpg --keyserver --recv-key E084DAB9
    gpg -a --export E084DAB9 | sudo apt-key add -
    gksudo gedit /etc/apt/sources.list

    then paste in the opened file the following line (or a similar one: see the link below):

    HTML Code:
    deb precise/

    regarding to the R mirrors, you find their complete list here:

    and finally type in a new Terminal window:
    sudo  apt-get update -y && sudo apt-get upgrade -y && sudo  apt-get dist-upgrade -y && sudo apt-get dselect-upgrade -y
    sudo apt-get install -y r-base
    Last edited by iMac71; February 22nd, 2013 at 12:17 PM.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts