Results 1 to 7 of 7

Thread: pulseaudio log errors

  1. #1
    Join Date
    Sep 2011
    Beans
    54
    Distro
    Ubuntu Development Release

    pulseaudio log errors

    pulseaudio[1721]: [pulseaudio] authkey.c: Failed to load authorization key '/var/lib/lightdm/.config/pulse/cookie': Invalid argument
    That is after I manually created the path and the file with "" content.

    Second error:
    pulseaudio[1726]: [pulseaudio] core-util.c: Failed to create secure directory (/run/user/lightdm/pulse): No such file or directory


    You can see this from "System Log"

  2. #2
    Join Date
    Feb 2007
    Location
    Rome, Italy
    Beans
    2,184

    Re: pulseaudio log errors

    same here:
    pulseaudio[1700]: [pulseaudio] authkey.c: Failed to open cookie file '/home/luca/.config/pulse/cookie': File o directory non esistente

  3. #3
    Join Date
    Aug 2010
    Location
    Arizona USA
    Beans
    2,989
    Distro
    Ubuntu Development Release

    Re: pulseaudio log errors

    Quote Originally Posted by anca-emanuel View Post
    pulseaudio[1721]: [pulseaudio] authkey.c: Failed to load authorization key '/var/lib/lightdm/.config/pulse/cookie': Invalid argument
    That is after I manually created the path and the file with "" content.

    Second error:
    pulseaudio[1726]: [pulseaudio] core-util.c: Failed to create secure directory (/run/user/lightdm/pulse): No such file or directory


    You can see this from "System Log"
    Nothing concerning "core-util.c", but...

    Yes, I use GDM (not LightDM) and I'm seeing...

    Code:
    pulseaudio[2580]: [pulseaudio] authkey.c: Failed to open cookie file '/var/lib/gdm/.config/pulse/cookie': No such file or directory
    pulseaudio[2580]: [pulseaudio] authkey.c: Failed to load authorization key '/var/lib/gdm/.config/pulse/cookie': No such file or directory
    Also...

    Code:
    pulseaudio[2583]: [pulseaudio] sink.c: Default and alternate sample rates are the same.
    Code:
    pulseaudio[4649]: [alsa-sink] alsa-sink.c: ALSA woke us up to write new data to the device, but there was actually nothing to write!
    pulseaudio[4649]: [alsa-sink] alsa-sink.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
    pulseaudio[4649]: [alsa-sink] alsa-sink.c: We were woken up with POLLOUT set -- however a subsequent snd_pcm_avail() returned 0 or another value < min_avail.
    Intel ® P4 Extreme Edition 3.4 (Gallatin) || DFI ® LanParty PRO875B rev B1
    Crucial ® Ballistix Tracer PC4000 1GB || Mountain Mods U2-UFO Opti-1203
    XFX 7600GT 560M AGP (PV-T73A-UDF3) || Corsair HX520W Modular PSU

  4. #4
    Join Date
    Feb 2007
    Location
    Rome, Italy
    Beans
    2,184

    Re: pulseaudio log errors

    I get choppy sound when pulseaudio is running, it eats all the cpu.
    Killing it I have a normal sound playback..

    so pulseaudio seems a bit buggy at the moment!

  5. #5
    Join Date
    Aug 2007
    Beans
    17

    Re: pulseaudio log errors

    I have exactly the same error, also the skype notification sound cracking.
    pulseaudio[2138]: [pulseaudio] core-util.c: Failed to create secure directory (/run/user/gdm/pulse): No such file or directory

    Any help will be grateful.

  6. #6
    Join Date
    May 2013
    Beans
    2

    Re: pulseaudio log errors

    Have same problem with lightdm:
    Code:
    [pulseaudio] authkey.c: Failed to open cookie file '/var/lib/lightdm/.config/pulse/cookie': No such file or directory
    [pulseaudio] authkey.c: Failed to load authorization key '/var/lib/lightdm/.config/pulse/cookie': No such file or directory
    Sometimes sound doesn't work after restart. Problems appeared after upgrade to 13.04.
    Quote Originally Posted by edkmho View Post
    I have exactly the same error, also the skype notification sound cracking.
    I have that problems too. This answer http://askubuntu.com/a/201747/132931 solved skype problem.
    Last edited by azurkin; May 3rd, 2013 at 10:32 AM.

  7. #7
    Join Date
    Oct 2013
    Beans
    1

    Re: pulseaudio log errors

    I seem to have fixed the "failed to load authorization file" error by copying .config/pulse/cookie out of my primary user's homedir and into /var/lib/lightdm/.config/pulse/cookie, then chown'ing the directory and the file to lightdm:lightdm, then restarting lightdm. That made the errors go away in my log, although it didn't fix the (apparently unrelated) login problem I'm having

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •