Results 1 to 10 of 10

Thread: Can't install nvidia-current after installing hardware enablement stack

  1. #1
    Join Date
    Feb 2013
    Beans
    11

    Question Can't install nvidia-current after installing hardware enablement stack

    Hello. This is my first post in Ubuntu Forums.

    I am running 12.04 precise pangolin LTS. I installed the LTS Hardware Enablement Stack using the following command:

    sudo apt-get install linux-generic-lts-quantal xserver-xorg-lts-quantal

    Everything installed correctly. I rebooted into the new kernel and found that everything works, so I uninstalled the old kernel 3.2.0 and restarted again.

    Strangely, now I cannot install the package nvidia-current. Here is the output:

    $ sudo apt-get install nvidia-current
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    nvidia-current : Depends: xorg-video-abi-11
    Depends: xserver-xorg-core (>= 2:1.10.99.901)
    E: Unable to correct problems, you have held broken packages.

    Question: Are there any special steps needed to install nvidia-current on 12.04 with hardware enablement?

    Furthermore, I wanted to know why there is a failed dependency, so I ran

    $ apt-cache show xserver-xorg-core-lts-quantal | grep Provides:

    and it gave me the following:

    Provides: xorg-input-abi-18, xorg-renamed-package, xorg-renamed-package-lts-quantal, xorg-video-abi-13, xserver-xorg-core

    Thus xserver-xorg-core-lts-quantal already provides xserver-xorg-core, so I am wondering why apt-get thinks that xserver-xorg-core is not installed?

  2. #2
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Can't install nvidia-current after installing hardware enablement stack

    xorg need to accept ABI > 11, but have not yet been upgraded; so have to wait

    https://bugs.launchpad.net/ubuntu/+s...l/+bug/1125413

  3. #3
    Join Date
    Feb 2010
    Location
    Nr BrandsHatch, S'oaks UK
    Beans
    1,241
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: Can't install nvidia-current after installing hardware enablement stack

    Hi!, bamm,

    You Posted
    Code:
    :I am running 12.04 precise pangolin LTS.
    Presumably that was 12.04.2, but was it from an update, or with a clean install ?.

    Both will show 12.04.2 from:
    Code:
    cat /etc/lsb-release
    but it needs 'uname -r' to distinguish, or the contents shown in Synaptic.

    When I tried to install a nvidia driver from Synaptic, [ Edit: in a clean install of 12.04.2] I got a warning that a lot of the 'lts-quantal' and backports files would be uninstalled, so I dropped it and installed the Nvidia.com downloaded driver, without problems.

    There are other similar reports - installing 'Steam'. for example.

    Chao!, bogan.
    Last edited by bogan; February 18th, 2013 at 10:28 PM. Reason: note added re version number
    "Better Solutions may bring Worsened Problems": After Lao Tse, b. circa 405BC. a contemporary of Confucius, who died circa 600BC.
    They did things differently in those days, apparently!!

  4. #4
    Join Date
    Feb 2013
    Beans
    11

    Re: Can't install nvidia-current after installing hardware enablement stack

    Hi Bogan,

    Yes I meant 12.04, not 12.04.2. In fact, the reason I installed the LTS Hardware Enablement Stack is to upgrade it to 12.04.2 without having to reinstall, because my system is already configured to my liking.

    I mentioned in my original post that I performed the upgrade by running the following command:

    sudo apt-get install linux-generic-lts-quantal xserver-xorg-lts-quantal

  5. #5
    Join Date
    Feb 2013
    Beans
    11

    Re: Can't install nvidia-current after installing hardware enablement stack

    Hi Dino99,

    Thanks for the explanation. Will a fix be out soon? If not, is there a way to revert my upgrade? Thanks.

  6. #6
    Join Date
    May 2011
    Location
    Alternate Universe
    Beans
    45
    Distro
    Xubuntu 18.04 Bionic Beaver

    Re: Can't install nvidia-current after installing hardware enablement stack

    Hi,

    Same thing happened to me, although I performed a clean new installation of 12.04.2
    Still, the Nvidia drivers are activated and in use, according to "Additional drivers" (jockey-gtk), showing up as "version current-updates" and it's 304. A bit old, but works perfect for me. Strangely, they activated themselves, contrary to all previous versions where you had to activate them.

    From what we see from dino99's post above, it's a bug, so we'll have to wait. I still didn't try downloading them from Nvidia's site as bogan said, but I'll check it out.

    Thanks.
    "Each choice we take creates a new reality. It's another path. The road not taken." Dr. Walter Bishop

  7. #7
    Join Date
    Feb 2013
    Beans
    11

    Re: Can't install nvidia-current after installing hardware enablement stack

    Hi Dino99,

    Is there any update yet on this issue? Thanks.

  8. #8
    Join Date
    Feb 2013
    Beans
    11

    Re: Can't install nvidia-current after installing hardware enablement stack

    What is the status of this bug?

  9. #9
    Join Date
    Feb 2013
    Beans
    11

    Re: Can't install nvidia-current after installing hardware enablement stack

    Hi Dino99,

    The bug you mentioned is tagged workaround-exist. However, running the workaround doesn't work for me. Would you know of a better solution? Thanks.

    Bamm

  10. #10
    Join Date
    Nov 2009
    Location
    Lake Wales Florida
    Beans
    607
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Can't install nvidia-current after installing hardware enablement stack

    sudo apt-get install xserver-xorg-lts-quantal libgl1-mesa-glx-lts-quantal

    This worked for me from a clean backup.I do use the latest nvidia from there site however.
    AMD FX-6200 - MSI 4.1Ghz- Nvidia GTX550Ti -12/GIG - 60GB-SSD/500 Sata - 12.04 - Gnome 3

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •