Results 1 to 3 of 3

Thread: Gnome session resets Xorg layout

  1. #1
    Join Date
    Feb 2013
    Beans
    2

    Gnome session resets Xorg layout

    Hi!

    I have Ubuntu 12.10 system with TwinView dualhead setup. I have correct Xorg.conf generated by nvidia-settings. After I login in GDM my .xinitrc runs:
    #!/usr/bin/env bash
    ~/.xinitrc.awesome &
    exec ck-launch-session gnome-session --session=gnome-fallback # ck-launch-session is advised for the dbus stuff to work fine.
    The problem is that gnome-session resets my TwinView setup and displays the same on both screens.

    The problem occured about a month ago (because of updates I think). I had no problems before.
    Is it a bug?

  2. #2
    Join Date
    Feb 2013
    Beans
    5

    Re: Gnome session resets Xorg layout

    Had some troubles myself with dual monitors, constantly wrong screen as primary, then found this post: http://ubuntuforums.org/showpost.php...93&postcount=4

    i solved my problem with:
    I had to disable the XrandR plugin for the gnome-settings-daemon because the default mirror setting interferes. I guess the Nvidia gui had been hiding that little issue. First install dconf-editor:
    Code:
    sudo apt-get install dconf-editor
    then open it. Now navigate to org.gnome.settings-daemon.plugins.xrandr and uncheck the active box for the xrandr plug-in. Your xrandr static configuration should no longer be overwritten when you restart.
    Onces i disabled xrandr, my dual monitor setup functions properly and follow xorg.conf

  3. #3
    Join Date
    Feb 2013
    Beans
    2

    Re: Gnome session resets Xorg layout

    Quote Originally Posted by MacBooom View Post

    Onces i disabled xrandr, my dual monitor setup functions properly and follow xorg.conf
    That worked for me. Thank you so much!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •