Results 1 to 3 of 3

Thread: NetworkManager isn't behaving properly in normal user, but works well in root user.

Threaded View

  1. #1
    Join Date
    Dec 2010

    Lightbulb [SOVLED]NetworkManager isn't behaving properly in normal user, but works well in root

    Hi, everyone. I'm using ubuntu 12.04, but I have replaced Unity with Mate(a fork of gnome2) by unistalling and installing lots of softwares. Everything seems fine, except the Network-Manager applet on the top panel. It just displays:
    NetworkManager is not running.
    OK, I run the code in terminal:
    sudo service network-manager start
    , then I get the message:
    start: Job is already running: network-manager.
    Then I tried to restart:
    sudo service network-manager restart.
    All right, something seems changed,
    network-manager stop/waiting, network-manager start/running, process 8955.
    But NetworkManager still cannot manage wireless and wired connections. It told me:
    No network devices are available.
    But I'm sure that the network devices are running properly, for I am using wireless network to communicate with you! What's more, If I login Mate with root instead of normal user, I can use the NetworkManager-applet properly. Can anyone tell me what's the matter?

    P.S. I cannot find the option or button to shutdown in normal user, but when I login by root, I can easily find the option in top menu to shutdown. Can anyone tell me how to add the shutdown option in normal user? What's the name of that shutdown software in top menu? Thanks a lot!
    Last edited by NewUserFF; February 17th, 2013 at 06:45 AM.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts