I installed 12.04 and when I would boot, it would stop and ask for a password.

I then installed Gnome fallback. It boots to the password prompt so i can choose what GUI to use.

Then I installed Virtualbox from the software options and wound up with a problem.

In Gnome, when I would start VB, it would immediately log me out and drop me back to the password entry.

I tried uninstalling and reinstalling from Synaptics. No change.

I tried logging into unity. In unity, when I would click on the dash, I would be returned to the log-in screen.

After reporting this to the VB forum, I was informed that my ubuntu installs of VB were edited so they would not support so I installed the Debian version from their website.

This fixed the logout problem, only maybe too well.

It worked in Gnome. So just to check it out, I logged into unity. After working here in Unity a while, I decided to drop back to Gnome again, where I can find my way around.

My problem is that I can shut down or reboot, but it ignores my logout or switch user account.

Now, when I boot, it automatically executes Unity without my logging in! I don't remember telling it to autolog me in.

I guess I need to find where to turn off autologin and how to go back to gnome.