Page 1 of 4 123 ... LastLast
Results 1 to 10 of 40

Thread: Wireless is disabled by hardware switch on Ubuntu 12.04.

  1. #1
    Join Date
    Feb 2013
    Beans
    21

    Red face Wireless is disabled by hardware switch on Ubuntu 12.04.

    I have instlled Ubuntu 12.04. on my Dell Inspirion Mini 1018. After doing one of regular updates, my wifi stop working, and it gives me message "Wireless is disabled by hardware switch".
    How can I enable it? I tried opening network connections, but there I find: Wireless Unavaible. Hardware Address 1C:65:9D:68:9E:6B


    Thank I tried System testing, it gives me a message: "# For some Atheros 5K RF MACs, the madwifi driver loads buts fails to
    # correctly initialize the hardware, leaving it in a state from
    # which ath5k cannot recover. To prevent this condition, stop
    # madwifi from loading by default. Use Jockey to select one driver
    # or the other. (Ubuntu: #315056, #323830)
    blacklist ath_pci"


    This what I get after mn-tool :
    Type: 802.11 WiFi
    Driver: rtl8192ce
    State: unavailable
    Default: no
    HW Address: 1C:65:9D:68:9E:6B

    Capabilities:

    Wireless Properties
    WEP Encryption: yes
    WPA Encryption: yes
    WPA2 Encryption: yes

    Wireless Access Points

    Next command I used sudo lshw -C network :

    *-network DISABLED
    description: Wireless interface
    product: RTL8188CE 802.11b/g/n WiFi Adapter
    vendor: Realtek Semiconductor Co., Ltd.
    physical id: 0
    bus info: pci@0000:07:00.0
    logical name: wlan0
    version: 01
    serial: 1c:65:9d:68:9e:6b
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=rtl8192ce driverversion=3.2.0-37-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
    resources: irq:17 ioport:3000(size=256) memory:f0100000-f0103fff


    How can I enable it?

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,230
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Wireless is disabled by hardware switch on Ubuntu 12.04.

    Please run and post:
    Code:
    rfkill list all
    dmesg | grep rtl
    Have you tried the wireless button F2?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  3. #3
    Join Date
    Feb 2013
    Beans
    21

    Re: Wireless is disabled by hardware switch on Ubuntu 12.04.

    rfkill list all
    1: dell-wifi: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes
    2: dell-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
    3: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
    4: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

    dmesg | grep rtl
    [ 26.466807] rtl8192ce 0000:07:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    [ 26.466830] rtl8192ce 0000:07:00.0: setting latency timer to 64
    [ 28.056166] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
    [ 28.064943] rtlwifi: wireless switch is on

  4. #4
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,230
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Wireless is disabled by hardware switch on Ubuntu 12.04.

    And how about the wireless button F2? Does that change anything?
    Code:
    rfkill list all
    Press F2.
    Code:
    rfkill list all
    Any changes?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  5. #5
    Join Date
    Feb 2013
    Beans
    21

    Angry Re: Wireless is disabled by hardware switch on Ubuntu 12.04.

    No reaction on F2, same results.
    rfkill list all
    1: dell-wifi: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes
    2: dell-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
    3: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
    4: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

    F@ rfkill list all
    1: dell-wifi: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes
    2: dell-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
    3: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
    4: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
    ljiljana@ljiljana-laptop:~$

  6. #6
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,230
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Wireless is disabled by hardware switch on Ubuntu 12.04.

    Please see if you have a module loaded dell-wmi.
    Code:
    lsmod | grep dell
    If so, let's try temporarily removing it:
    Code:
    sudo modprobe -r dell-wmi
    sudo rfkill unblock all
    rfkill list all
    Any change?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  7. #7
    Join Date
    Feb 2013
    Beans
    21

    Question Re: Wireless is disabled by hardware switch on Ubuntu 12.04.

    On a first command I got this:

    dell_laptop 17767 0
    dcdbas 14098 1 dell_laptop


    Before I start next step, just wanted to say, I have AipPlane Mode ON all the time, I can't switch it. I tried few times, but it always goes back on. Curious, does this can provoke disabled wifi? If you know how to disable AirPlane Mode, please, tell me. Perhaps only through terminal?

  8. #8
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,230
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Wireless is disabled by hardware switch on Ubuntu 12.04.

    Airplane Mode simply means the switch is set to disable the wireless radio.

    Please proceed.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  9. #9
    Join Date
    Feb 2013
    Beans
    21

    Red face Re: Wireless is disabled by hardware switch on Ubuntu 12.04.

    ljiljana@ljiljana-laptop:~$ sudo modprobe -r dell-wmi
    [sudo] password for ljiljana:
    WARNING: All config files need .conf: /etc/modprobe.d/blacklist, it will be ignored in a future release.
    ljiljana@ljiljana-laptop:~$ sudo rfkill unblock all
    ljiljana@ljiljana-laptop:~$ rfkill list all
    0: dell-wifi: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes
    1: dell-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
    2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
    5: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
    ljiljana@ljiljana-laptop:~$

  10. #10
    Join Date
    Feb 2013
    Beans
    21

    Question Re: Wireless is disabled by hardware switch on Ubuntu 12.04.

    Did all you asked, and posted in my last replay.
    Here is a second thing that is not normal (at least I think it is not normal).... Look at this, please: AirPlane Mode that is always ON. Just wanted to know what instruction I use to put it to sleep? When I just press OFF button, it switches for a short time, till I close network connection, or I go other settings. Same moment I do anything else it goes back to ON. Is there some way to prevent it and keep my laptop out of AirPlane Mode?
    Maybe we should finish first what we started, than this, but I am just a bit confuzed with all this. Thanks for helping me !!
    Attached Images Attached Images

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •