Results 1 to 3 of 3

Thread: Unable to load windows 7

  1. #1
    Join Date
    Feb 2013

    Unhappy Unable to load windows 7


    I had an Acer laptop that had Ubuntu and Windows 7 on it. I wanted to get rid of Ubuntu so I went into disk management and deleted the volume in the partition in which Ubuntu was placed. After doing this I continued to use the computer for a bit longer and then turned it off. Upon returning and turning the computer back on I arrived at a black screen that said

    error: unknown filesystem
    grub rescue>

    I have no idea what to do or what happened. I had 5 partitions created and all I did was delete the volume from one of them. I am extremely confused on what to do and I need to be able to open Windows back up.

    I have already tried the command:

    ls (hd0,msdos1/2/3/5)

    I have tried that command with those 4 numbers switched in and I got the response unknown filesystem every time. Could someone please help me, I am extremely lost and confused on what to do.

  2. #2
    Join Date
    Apr 2009
    UK Lake District
    Ubuntu 16.04 Xenial Xerus

    Re: Unable to load windows 7

    You need the windows dvd to fix the windows bootloader.
    Ubuntu Member Always something different. Promoting Ubuntu and System 76 at TUXPC

  3. #3
    Join Date
    Jun 2009
    SW Forida
    Ubuntu 16.04 Xenial Xerus

    Re: Unable to load windows 7

    You just need a Windows boot loader in the MBR. Grub in the MBR is looking for the rest of grub including grub menu in the partition you deleted.

    You can use a Windows repairCD to run auto repairs 3 times (yes 3x) or manually the fixMBR command.

    Or you can use Ubuntu liveCD and install a boot loader that will boot Windows.

    How to restore the Ubuntu/XP/Vista/7 bootloader

    Boot Repair -Also handles LVM, GPT, separate /boot and UEFI dual boot.:

    Restore basic windows boot loader - universe enabled if error on lilo not found
    Simply open Synaptic and Settings > Repositories and tick the box against the Universe repo in the Ubuntu Software tab. Close that window and click on reload before installing lilo with Synaptic or command line.
    sudo apt-get install lilo
    sudo lilo -M /dev/sda mbr
    May show error messages about the rest of lilo missing, ignore, we just want MBR with bootloader.
    For more info on UEFI boot install & repair - Regularly Updated :
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts