Results 1 to 3 of 3

Thread: Ubuntu 12.10 does not boot properly

  1. #1
    Join Date
    Feb 2013

    Ubuntu 12.10 does not boot properly

    Hi everyone,

    I decided to drop Wubi because I had issues with fglrx which the Wubi installation might have exacerbated. So I initially installed Ubuntu 12.04 on one of my hard drives and then replaced Unity with Gnome Shell. After discovering that 12.04 uses Gnome 3.4 and not 3.6, I upgraded Ubuntu to 12.10 and install Gnome 3.6.

    Now this morning when I woke up, it wouldn't boot properly. By pressing Ctrl-Alt-F2 (or maybe just Alt-F2 was needed), I got a command prompt. I was able to start a graphical interface by using
    These are the things that I noticed:
    • There was no top bar or dash (I installed DockbarX), just the desktop icons
    • I got a prompt that said the Gnome keyring was not unlocked and it asked for my password again
    • I got another prompt later on saying something about a change in language. I canceled it, but the language still changed to what seemed like Chinese
    • Programs had to be opened through the terminal, and I was unable to alt-tab

    I am hoping that I wouldn't have to reinstall the whole thing. I just want to know if there is a way to repair the installation or reset it to default settings.



    I'm in the office right now so I can't try any suggestions right away, sorry.

  2. #2
    Join Date
    Jun 2009
    SW Forida
    Ubuntu 16.04 Xenial Xerus

    Re: Ubuntu 12.10 does not boot properly

    I have nVidia, so I have not followed AMD. But there was some info where AMD dropped support for older cards.

    With nVidia and I think the newer AMD drivers you have to install linux headers first with 12.10 or it will not install correctly.
    sudo apt-get install linux-headers-generic
    Ubuntu Precise Installation Guide - AMD/ATI
    Add Hardware Graphics - ATI: After installing ATI Driver: From QIII
    On the proprietary driver side, the AMD Catalyst 12.11 Beta Linux graphics driver was used. For this initial testing, three discrete graphics cards from the AMD Radeon HD 5000/6000 series were used, since pre-HD5000 graphics cards are now on the Catalyst Legacy driver and the latest-generation Radeon HD 7000 series hardware still doesn't fully work with the open-source Gallium3D "RadeonSI" driver.

    For more info on UEFI boot install & repair - Regularly Updated :
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  3. #3
    Join Date
    Feb 2013

    Re: Ubuntu 12.10 does not boot properly


    Thanks for your reply I've decided to just take the plunge and dual-boot Ubuntu with Windows using separate hard drives. I haven't had time to install the AMD driver, but since Gnome Shell went broke on me, I think the problems had more to do with GS than with the driver.


Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts