Results 1 to 2 of 2

Thread: Wireless not working after kernel upgrade

  1. #1
    Join Date
    Jul 2010
    Beans
    100

    Wireless not working after kernel upgrade

    My kernel updated to 3.2.0-36 last week, and my wifi stopped working - it could still see networks, but would not connect. The card, I'm afraid, is Broadcom 4313. I had been using proprietary drivers, generally ok.

    To fix, I tried everything, uninstalling bcmwl kernel source, broadcom sta common and source through Ubuntu Software Center. Then tried removing and activating proprietary drivers through System Settings (Jockey). Nothing worked.

    Eventually did sudo apt-get purge on all three of the above, and got a weak connection - with brmcsmac driver. This I can't understand, my blacklist file

    /etc/modprobe.d/blacklist.conf

    contains a line whcih I thought stopped this driver loading.

    # poor wireless 2
    blacklist brmcsmac

    Anyone got any ideaas what is happening? I suspect the blacklisting isn't working and both brmcsmac and proprietary drivers are trying to grab the wireless card. And how can I fix it?

    The only other thing I noted was a backup blacklist file


    /etc/modprobe.d/blacklist.conf~

    Which is the same as the original. Should I delete it, and how?

    Thanks for reading!


  2. #2
    Join Date
    Jul 2010
    Beans
    100

    Re: Wireless not working after kernel upgrade

    Solved - apparently due to latest version of Broadcom proprietary driver not being compatible with Ubuntu 12.04. Need to revert to previous version.

    See pages 2 and 3 on this thread

    http://ubuntuforums.org/showthread.php?t=2111403

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •