Results 1 to 2 of 2

Thread: SMB wrong permission copying folder

  1. #1
    Join Date
    Feb 2013

    Angry [SOLVED]SMB wrong permission copying folder

    Hi at all

    I need help.
    I installed a new Ubuntu server with SMB packets.
    I configured it with some users and some group.
    I configured some folder for different acces depending on groups.
    I configured SMB to create folders only with 0770 permission with parameters create mask = 0770 and directory mask = 0770

    When I create e new folder, all have right permission.
    When I copy folder from different folders or from windows client, permission is 0750 and folder is not accessible from other group users.
    It happen only when i copy folders.
    I need that SMB create/copy folders only with 0770 permissions.

    Can someone help me?

    If it's need, I can post my smb.conf and my testparm results.

    PS: sorry for my poor english language
    Last edited by Cruell; February 5th, 2013 at 05:10 PM. Reason: [SOLVED]

  2. #2
    Join Date
    Feb 2013

    Re: SMB wrong permission copying folder

    It was che UMASK parameter.
    I changed it in file /etc/login.defs from 022 to 002.
    That's all


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts