Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: please help open close ports!

  1. #1
    Join Date
    Mar 2006
    Location
    Earth
    Beans
    576
    Distro
    Ubuntu 14.04 Trusty Tahr

    please help open close ports!

    Hi Community:

    A few days ago, I got paranoid and decided to investigate increasing the security of some things. The thread of that security discussion is found at:

    http://ubuntuforums.org/showthread.php?t=2111909

    I did a few things like install gufw and a few other things recommended at that thread. Also, I uninstalled gufw.

    I've found that my ubuntu machine (12.04), can no longer:
    • cannot be accessed frm other devices on my network, and
    • people with whom I shared files on Ubuntu one can no longer see the contents of my shared folders.


    I think I must have inadvertently closed ports or something like that... although I'm not really certain what happened.

    Could someone please suggest how I might allow communication from other computers and devices on my home network and fix my problem with other accessing my shared folders on Ubuntu One?

    Thanks,
    Old Jimma

  2. #2
    Join Date
    Apr 2009
    Location
    UK Lake District
    Beans
    3,093
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: please help open close ports!

    If enable a firewall
    You'll need to open no standard ports in the firewall settings
    Ubuntu Member Always something different. Promoting Ubuntu and System 76 at TUXPC

  3. #3
    Join Date
    Aug 2006
    Beans
    12,948
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: please help open close ports!

    The obvious, if only temporary, moves would be to stop being paranoid, and disable the firewall. Then learn whether you even need one, and if so, learn how to configure it.

  4. #4
    Join Date
    Mar 2006
    Location
    Earth
    Beans
    576
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: please help open close ports!

    I don't have a firewall. gufw and firestarter are not installed.

  5. #5
    Join Date
    Dec 2005
    Location
    Western Australia
    Beans
    11,480
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: please help open close ports!

    Quote Originally Posted by Old Jimma View Post
    I don't have a firewall. gufw and firestarter are not installed.
    Yes, you still have a firewall running.

    gUFW and Firestarter are just programs to make it easy to use the inbuilt Linux firewall. Removing gUFW will not turn off the firewall.

    Reinstall gUFW and turn off the firewall (allow all incoming and outgoing ports). THEN you can remove gUFW if you wish.
    Last edited by 3rdalbum; February 5th, 2013 at 11:16 AM.
    I try to treat the cause, not the symptom. I avoid the terminal in instructions, unless it's easier or necessary. My instructions will work within the Ubuntu system, instead of breaking or subverting it. Those are the three guarantees to the helpee.

  6. #6
    Join Date
    Mar 2011
    Location
    UK
    Beans
    125
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: please help open close ports!

    Hi

    The ubuntu firewall is ufw (Uncomplicated FireWall) and it's command line only. gufw just adds a fancy front end to configure ufw with. If you want to turn off the firewall run from a terminal

    Code:
    sudo ufw disable
    or to open and close ports

    Code:
    sudo ufw allow 8022
    sudo ufw deny 8022
    hope this helps!

    Barry
    Desktop: Z77X-UD5H, Intel i7 3770k, NVidia GeForce 660 Ti Sli 16GB DDR3 RAM 2TB HDD
    OSes: Mint 14 x64 Windows 7 Ultimate x64
    Laptop: Dell Latitude E6430
    OSes: Ubuntu 13.04 x64, Backtrack 5 R3

  7. #7
    Join Date
    Jan 2013
    Location
    Another Dimension
    Beans
    164
    Distro
    Kubuntu 12.10 Quantal Quetzal

    Re: please help open close ports!

    Hi

    The ubuntu firewall is ufw (Uncomplicated FireWall) and it's command line only. gufw just adds a fancy front end to configure ufw with. If you want to turn off the firewall run from a terminal

    Code:
    sudo ufw disable
    or to open and close ports

    Code:
    sudo ufw allow 8022 sudo ufw deny 8022
    hope this helps!

    Barry
    Or just flush iptables

    Code:
    sudo su
    iptables -F iptables -X 
    iptables -t nat -F 
    iptables -t nat -X 
    iptables -t mangle -F 
    iptables -t mangle -X 
    iptables -P INPUT ACCEPT 
    iptables -P FORWARD ACCEPT 
    iptables -P OUTPUT ACCEPT

  8. #8
    Join Date
    Dec 2005
    Location
    Western Australia
    Beans
    11,480
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: please help open close ports!

    Quote Originally Posted by furything View Post
    Or just flush iptables

    Code:
    sudo su
    iptables -F iptables -X 
    iptables -t nat -F 
    iptables -t nat -X 
    iptables -t mangle -F 
    iptables -t mangle -X 
    iptables -P INPUT ACCEPT 
    iptables -P FORWARD ACCEPT 
    iptables -P OUTPUT ACCEPT
    I appreciate that you're giving completeness to the answer, but you might confuse the poor chap Just disabling UFW with one command or using gUFW is probably going to be easier for him.
    I try to treat the cause, not the symptom. I avoid the terminal in instructions, unless it's easier or necessary. My instructions will work within the Ubuntu system, instead of breaking or subverting it. Those are the three guarantees to the helpee.

  9. #9
    Join Date
    Jan 2013
    Location
    Another Dimension
    Beans
    164
    Distro
    Kubuntu 12.10 Quantal Quetzal

    Re: please help open close ports!

    I appreciate that you're giving completeness to the answer, but you might confuse the poor chap Just disabling UFW with one command or using gUFW is probably going to be easier for him.
    Yeah sorry I don't use ufw. Have always gone into the nuts and bolts so to speak.

  10. #10
    Join Date
    Dec 2008
    Location
    USA
    Beans
    524
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: please help open close ports!

    Since ufw and gufw control iptables I would do this.

    sudo service iptables stop

    see if that fixes the problem, then you can fine tune it from there. It is not recommended to leave the firewall off.
    I don' really like coffee. I guess I'll give my Ubuntu beans to my wife.

    Luke

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •