Results 1 to 2 of 2

Thread: Brightness Control on Acer Aspire 5732Z (Laptop)

Threaded View

  1. #1
    Join Date
    Feb 2013

    Talking Brightness Control on Acer Aspire 5732Z (Laptop) -Fixed-

    First off, I'm new as of yesterday to Linux, so I'm lacking specific knowledge...

    I installed Ubuntu 12.10 using an external monitor as the backlight was not working on the laptop.
    Then, I installed mesa-utils which changed the graphics status from unknown to: Mobile Intel® GM45 Express Chipset x86/MMX/SSE2
    Still without a fix, I tried:
    echo 65 | sudo tee /sys/class/backlight/intel_backlight/brightness
    which finally turned the laptops backlight on, though only each time I run it.
    On the same post I found this code, it said to edit grub.cfg to:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" acpi_backlight=vendor
    which I did, but nothing changed after I updated grub and rebooted.

    I'm looking for a way to make the backlight always be on, rather than having to type the first set of code into the terminal every time, but I'm too much of a noob to know how to do this...
    Any help?

    Additional: My fn key doesn't work (hardware problem) so I can't control brightness this way.

    -- Fix --

    Follow this guide:
    replace "lampp" with whatever you decide to name the script, and replace the 2nd line (after using nano) with the first code mentioned in this post. Then reboot to check it worked.
    Last edited by ksbd; February 3rd, 2013 at 03:58 PM. Reason: Found a fix

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts