Results 1 to 9 of 9

Thread: gnuplot / x11 not working

  1. #1
    Join Date
    Feb 2013
    Beans
    11

    gnuplot / x11 not working

    Hello everybody.
    I got a new laptop recently and installed gnuplot. The problem now is, that the terminal type of gnuplot is set to unknown and I can't set it to x11 (with which I guess it should work as it is supposed to do). Now when I try plotting no plot is coming out, just the next command line appears.
    I've tried installing different x11-packages, however gnuplot is not recognizing them.
    Can you please tell me how to understand if now I have the right x11 package and how to make gnuplot work with it.
    Thank you in advance!
    Irina

  2. #2
    Join Date
    Apr 2012
    Beans
    7,256

    Re: gnuplot / x11 not working

    Hello and welcome

    What terminal types are listed if you type 'set terminal' on its own at the gnuplot prompt?

    Code:
    gnuplot> set terminal
    What version of Ubuntu are you running and how did you install gnuplot?

    FWIW I believe the default terminal type is now 'wxt' (wxWindows based)

  3. #3
    Join Date
    Feb 2013
    Beans
    11

    Re: gnuplot / x11 not working

    Hello. Thank you for the quick reply!
    I use ubuntu 12.10 (32bit). In the very beginning I installed gnuplot with sudo apt-get install command line, but after trying to fix the problem I reinstalled it with the software centre.
    The listed terminal types are:
    canvas
    cgm
    context
    corel
    dumb
    dxf
    eepic
    emf
    emtex
    epscairo
    epslatex
    fig
    gif
    gpic
    hp2623A
    hp2648
    hpgl
    imagen
    jpeg
    latex
    lua
    mf
    mif
    mp
    pcl5
    pdfcairo
    png
    pngcairo
    postscript
    pslatex
    pstex
    pstricks
    qms
    regis
    svg
    tek40xx
    tek410x
    texdraw
    tgif
    tikz
    tkcanvas
    tpic

  4. #4
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: gnuplot / x11 not working

    after tpic I have also these

    Code:
              unknown  Unknown terminal type - not a plotting device
                vttek  VT-like tek40xx terminal emulator
                  wxt  wxWidgets cross-platform windowed terminal
                  x11  X11 Window System
                 xlib  X11 Window System (gnulib_x11 dump)
                xterm  Xterm Tektronix 4014 Mode
    And as as Steeldriver wrote, my default terminal type is 'wxt', which works (can plot in X). I run lubuntu-desktop in Ubuntu 12.04 LTS.

  5. #5
    Join Date
    Feb 2013
    Beans
    11

    Re: gnuplot / x11 not working

    yes, my mistake
    I also have

    unknown
    vttek

    and that's it

  6. #6
    Join Date
    Apr 2012
    Beans
    7,256

    Re: gnuplot / x11 not working

    it looks like you don't have the gnuplot-x11 package installed - it should have installed as a dependency of gnuplot afaik - unless for some reason your system doesn't support it? you could try

    Code:
    sudo apt-get update
    sudo apt-get install gnuplot-x11
    ... at least if it results in an error it may tell us why

    Your terminal list looks like what you'd get with gnuplot-nox
    Last edited by steeldriver; February 1st, 2013 at 07:06 PM.

  7. #7
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: gnuplot / x11 not working

    .
    Last edited by sudodus; February 1st, 2013 at 07:22 PM. Reason: Steeldriver's recipe works, so I wipe this post

  8. #8
    Join Date
    Feb 2013
    Beans
    11

    Re: gnuplot / x11 not working

    beautiful. I was working with -nox without knowing it. now I get my plots as usual.
    I was also considering installing the LTS, but this will take time, which I don't have now.....
    thanks a lot for the help!

  9. #9
    Join Date
    Apr 2012
    Beans
    7,256

    Re: gnuplot / x11 not working

    OK glad that worked - please take the time to mark the thread as SOLVED

    For the record, it *does* look like the dependencies have changed from precise to quantal - it has gone from

    Precise:

    • gnuplot-nox (>= 4.4.3-0ubuntu3) A command-line driven interactive plotting program


    • gnuplot-x11 (>= 4.4.3-0ubuntu3) A command-line driven interactive plotting program


    Quantal:

    • gnuplot-nox Command-line driven interactive plotting program. No-X package also a virtual package provided by gnuplot-qt, gnuplot-x11

    or gnuplot-x11 Command-line driven interactive plotting program. X-package also a virtual package provided by gnuplot-qt
    or gnuplot-qt Command-line driven interactive plotting program. QT-package

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •