I have had a watermark (semi-transparent) icon on the lower right corner of my screen for some time.

It first appeared when I tried one of the "Additional Drivers" found by System Settings.

I recently got the following from AMD : "Please note that this issue has been resolved with our latest CAT 13.1 driver. http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx?type=2.4.1&product= ng=English"

So I've been waiting for an update including the new drivers. An update arrived today, but it did NOT fix the problem. How do I check the version of the drivers in the recent update to make sure they are the right (latest) ones?

But MUCH more importantly, how do I get rid of the #%^$^%& watermark icon?

I've tried all of the Additional Driver options with the following results:
- first one in the list - Works, but exchanged the "Unsupported" icon for a "3D Testing Only (or similar)" icon.
- second one - Works, but has "Unsupported" icon
- third one - "Post Release Updates" - would not complete installation
- using none of them - STILL has "Unsupported" icon