While using Transmission to download a torrent it kept greying out and not responding. I used the Force Quit function from my panel without success and tried to kill the process using the system monitor again without success. The process ended up being a zombie. I restarted and when I tried Transmission again it happened again.

This time I used alt-sysreq-k instead of restarting and when I logged back in, my Desktop was blank, panels were blank. The following seems to have been lost:
All files and folders from Desktop, Downloads folder
Chromium settings
Nautilus settings (such as having the close button on the right)

My home directory has not been wiped though and I noted that my Documents folder is still intact. Other stuff has probably been lost as well but I didn't investigate too far.

I've shutdown to prevent further data loss.

The issue with Transmission may have been entirely unrelated. Has anyone ever come across something similar before or suffered data loss like this? Is there a simple fix or do I need to resort to scanning the hard drive to recover lost files?