Results 1 to 6 of 6

Thread: 12.04 AMD64: New install; upgrade breaks grub2

  1. #1
    Join Date
    Jan 2013
    Beans
    9

    12.04 AMD64: New install; upgrade breaks grub2

    I have recently constructed a new computer and installed Ubuntu 12.04.1 LTS AMD64 on it. The hardware is:
    MSI FM2-A75MA-E35 motherboard
    AMD A6 5400K CPU
    Patriot PC3 - 12800 8GB (2x4GB) memory
    Seagate 160GB SATA-6G Barracuda 7200.12 hard drive
    Dell 1704FPT (17" LCD) (VGA connection via Trulink KVM)

    Installing appears to work OK, but after I install the proprietary ATI driver to get to the Dell's optimum resolution, I get all kinds of errors, notably, after restarting I get:
    Code:
    error: hd0 out of disk
    grub: rescue> _
    I then booted from a USB stick with Ubuntu Secure Remix (12.10 64-bit), and ran boot-repair from the DASH. Resulting message was:
    Code:
    Boot Repair
    Please write on a paper the following URL:
    http://paste.ubuntu.com/1574401
    In case you still experience boot problem, indicate this URL to:
    boot.repair@gmail.com
    You can now reboot your computer.
    After rebooting, I get:
    Code:
    error: invalid arch independent ELF magic.
    grub rescue> _
    FWIW: I've been using the Trulink 4-port KVM and Dell 1704 with 4 other machines for at least 2 years now. Attached machines have all been AMDs, and have been running various 64-bit versions of Ubuntu (8.04, 10.04, 11.04 and 12.04) with no problems.

    Any and all help would be appreciated. Thanks.

    Dirk

  2. #2
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: 12.04 AMD64: New install; upgrade breaks grub2

    you might first watch possible errors about each partition shown by gparted

  3. #3
    Join Date
    Jan 2013
    Beans
    9

    Re: 12.04 AMD64: New install; upgrade breaks grub2

    Quote Originally Posted by dino99 View Post
    you might first watch possible errors about each partition shown by gparted
    Thanks for the suggestion; ran gparted and checked the /dev/sda1 partition. No errors.

    Note: When installing Ubuntu 12.04.1 AMD64 (4 times so far), I installed using all defaults, including partitioning.

  4. #4
    Join Date
    Nov 2009
    Location
    Mataro, Spain
    Beans
    13,668
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: 12.04 AMD64: New install; upgrade breaks grub2

    I can't notice anything wrong in the bootinfo. Can you attach the monitor directly at least until you finish the post-install configuration and driver activation? Just to make sure the KVM is not interfering.

    Also double check the hdd cables, and try it in another sata port.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 14.04 LTS 64bit & Windows 10 Pro 64bit

  5. #5
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: 12.04 AMD64: New install; upgrade breaks grub2

    I do not understand why Boot-Repair had issues writing to your system? Is it encrypted?

    Even though your drive is not large, what mode is BIOS in? It should be LBA, large, AHCI but not IDE.
    History of BIOS and IDE limits
    http://tldp.org/HOWTO/Large-Disk-HOWTO-4.html
    Out of disk error add to grub install disk-module=ata or use Boot-Repair ATA Disk support
    HOWTO: dualboot on big disk (BIOS limitations)
    https://help.ubuntu.com/community/In...buntuOnBigDisk
    http://ubuntuforums.org/showthread.php?t=1998257

    Boot-Repair may have partially updated grub by installing the liveCD's version of grub, but then could not write the rest?

    error: invalid arch independent ELF magic

    Often version of grub in MBR is not same as install.
    Use same version to reinstall or chroot and fully uninstall & reinstall.

    This issue is more common on very large drives over 500GB.
    Also with large drives, grub files or kernels can be beyond 100GB and cause issues booting. Your files currently are all close to start of drive, but it may be better to have a / (root) of 25GB and use rest of drive for /home or data partition. Future updates may put files beyond the 100GB and then give similar out-of-disk errors. May be BIOS or grub, we are not really sure, but smaller root or separte /boot usually solve that issue.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  6. #6
    Join Date
    Jan 2013
    Beans
    9

    Re: 12.04 AMD64: New install; upgrade breaks grub2

    Thank you to oldfred and darkod for your suggestions. I am still baffled as to what's happening, but it appears I have partially "solved" the issue. Notes on questions:
    - There is nothing wrong with the SATA port I'm using (I did try a different one but made no difference).
    - Hard drive is not encrypted.
    - Double-checked BIOS; disks are in AHCI mode.

    Re-installing:
    - Attached monitor directly to computer (mouse and keyboard remain attached to KVM)
    - Partitioned so /boot is first partition at 16GB; /swap is last partition at 16GB; remainder is /
    - Otherwise, everything left at defaults.

    This time, the installer noted something about restoring previously installed software (even though I told it to reformat all partitions for which it allows formatting).

    I cannot say for sure which of the changes I made mitigated the grub problem (I suspect it's the partitioning).

    Rebooted fine (apparently no need to re-install grub), but I get an error during login if I attach the monitor to the KVM "1: Analog Input Cannot Display This Video Mode" If I re-attach monitor to computer, I can log in, and then re-attach to the KVM. Anyone have any idea of where login's video mode could be set to match that of when I'm logged in?

    Marked this issue as solved. May post KVM/LightDM issue in separate thread.
    Last edited by dtheurer; January 29th, 2013 at 07:27 PM. Reason: Different problem now

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •