Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: wl module has to be restarted after boot for wirless to work

  1. #1
    Join Date
    Jun 2009
    Beans
    32

    Red face wl module has to be restarted after boot for wirless to work

    Hi, I have a very strange problem. I am starting a new thread since I probably tried every solution founds on forums and nothing exactly solves the problem although I am now very close. So, I did a fresh install of ubuntu 12.04 yesterday on a Dell Latitude e4300 laptop. There were problems with the wireless and I finally got it to work with the wl driver after tweaking things, blqcklisting other drivers etc as mentioned in various threads. However the connection was very slow. This was the same problem I had with another laptop (an asus eee pc) with the same network. I initially thought it was a problem of that laptop. Since I now had this problem on two different machines, I looked it up and there are actually many threads on this kind of problems that mention an option called disable_11n, presumably it also had to do with the hardware of my provider (free.fr). I tried all that and to cut a long story short i narrowed down the problem to the following:

    1.after startup and logging on to unity the wireless connects automatically to my network but the connection is slow to non existent

    2. after that i open a terminal and type

    Code:
    sudo rmmod  wl
    (wireless gets disabled)
    Code:
    sudo modprobe wl
    (wireless gets re-enabled after half a minute or so)

    3. it automatically connects again to my network and works like a charm! and fast too.


    I then tried to do this as a startup script. I followed instructions to make it work from init.d , add it to rc.locale and to /etc/modules, one at a time. I still had to restart it as above and only then it would work. I am not sure if i did something wrong here.

    By the way the option disable_11n=1 seems irrelevant to my problem.

    Note that I have this problem only for free.fr wireless boxes (my provider hardware) and on two ubuntu machines. I wouldn't know where to start to give you some useful output as I am very confused as to where the problem actually resides (driver, laptop hardware,ubuntu ,provider hardware, bad script skills). My problem then is how to make this a permanent solution.

    Some possibly relative output I can think of is (I note if there is any difference in the output before and after having disabled re-enabled wl)

    Code:
    marios@mrLap:~$ lspci | grep Wireless
    0c:00.0 Network controller: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller (rev 01)
    Code:
    marios@mrLap:~$ iwconfig
    lo        no wireless extensions.
    
    eth2      IEEE 802.11  Access Point: Not-Associated  
              Link Quality:5  Signal level:214  Noise level:166
              Rx invalid nwid:0  invalid crypt:0  invalid misc:0
    
    eth0      no wireless extensions.
    (similar signal and noise levels before and after, same linq quality)


    This is the before ifconfig
    Code:
    eth0      Link encap:Ethernet  HWaddr 00:26:b9:96:a3:02  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 lg file transmission:1000 
              Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)
              Interruption:22 Mémoire:f6ae0000-f6b00000 
    
    eth2      Link encap:Ethernet  HWaddr 90:4c:e5:77:a8:90  
              inet adr:192.168.1.49  Bcast:192.168.1.255  Masque:255.255.255.0
              adr inet6: 2a01:e34:edf9:1990:a4c0:ddea:66c1:53b7/64 Scope:Global
              adr inet6: 2a01:e34:edf9:1990:924c:e5ff:fe77:a890/64 Scope:Global
              adr inet6: fe80::924c:e5ff:fe77:a890/64 Scope:Lien
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              Packets reçus:263 erreurs:0 :0 overruns:0 frame:1842
              TX packets:461 errors:19 dropped:0 overruns:0 carrier:0
              collisions:0 lg file transmission:1000 
              Octets reçus:196451 (196.4 KB) Octets transmis:69054 (69.0 KB)
              Interruption:17 Adresse de base:0xc000 
    
    lo        Link encap:Boucle locale  
              inet adr:127.0.0.1  Masque:255.0.0.0
              adr inet6: ::1/128 Scope:Hôte
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              Packets reçus:81 erreurs:0 :0 overruns:0 frame:0
              TX packets:81 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 lg file transmission:0 
              Octets reçus:8642 (8.6 KB) Octets transmis:8642 (8.6 KB)
    and this the after
    Code:
    marios@mrLap:~$ ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:26:b9:96:a3:02 
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 lg file transmission:1000
              Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)
              Interruption:22 Mémoire:f6ae0000-f6b00000
    
    eth2      Link encap:Ethernet  HWaddr 90:4c:e5:77:a8:90 
              inet adr:192.168.1.49  Bcast:192.168.1.255  Masque:255.255.255.0
              adr inet6: 2a01:e34:edf9:1990:924c:e5ff:fe77:a890/64 Scope:Global
              adr inet6: fe80::924c:e5ff:fe77:a890/64 Scope:Lien
              adr inet6: 2a01:e34:edf9:1990:6c9c:c93b:31f5:59e/64 Scope:Global
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              Packets reçus:1220 erreurs:0 :0 overruns:0 frame:12988
              TX packets:1292 errors:19 dropped:0 overruns:0 carrier:0
              collisions:0 lg file transmission:1000
              Octets reçus:1116056 (1.1 MB) Octets transmis:194483 (194.4 KB)
              Interruption:17 Adresse de base:0xc000
    
    lo        Link encap:Boucle locale 
              inet adr:127.0.0.1  Masque:255.0.0.0
              adr inet6: ::1/128 Scope:Hôte
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              Packets reçus:1259 erreurs:0 :0 overruns:0 frame:0
              TX packets:1259 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 lg file transmission:0
              Octets reçus:93783 (93.7 KB) Octets transmis:93783 (93.7 KB)
    The output is exactly the same in both cases for lsmod |grep wl and rfkill list wifi

    Code:
    marios@mrLap:~$ lsmod |grep wl
    wl                   2646632  0
    lib80211               14040  2 wl,lib80211_crypt_tkip
    Code:
    marios@mrLap:~$ rfkill list wifi
    1: dell-wifi: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    2: brcmwl-0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    Last edited by psifunk; January 22nd, 2013 at 04:01 PM. Reason: typos

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,906
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: wl module has to be restarted after boot for wirless to work

    I love a mystery.

    disable_11n
    Where and how did you do this? May I see:
    Code:
    lspci -nn | grep 0280
    While I study your results, please try editing Network Manager to ignore IPv6 as shown attached. Then reboot and let me have your report.
    Attached Images Attached Images
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    Jun 2009
    Beans
    32

    Re: wl module has to be restarted after boot for wirless to work

    Hi chili555, thanks for the interest.

    The 11n_disable=1 option seems to be a solution proposed often for slow wifi connection problems relative to iwlwifi and iwlagn modules. I initialy thought this was the problem but I don't think its relative any more. In order for that option to work I had to stop and restart the modules. After tweaking around I realised that I don't need iwlwifi to be running or that option, and that what was making it work was restarting wl. I had created a configuration file in /etc/moprobe.d/ where I had only this option , namely it read

    options iwlagn 11n_disable=1

    I deleted this file before starting the thread here. This method is for example mentioned at

    http://askubuntu.com/questions/13049...wireless-cards

    Here's the output you requested
    Code:
    marios@mrLap:~$ lspci -nn | grep 0280
    0c:00.0 Network controller [0280]: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller [14e4:432b] (rev 01)
    Last edited by psifunk; January 22nd, 2013 at 04:40 PM.

  4. #4
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,906
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: wl module has to be restarted after boot for wirless to work

    After tweaking around I realised that I don't need iwlwifi to be running or that option,
    Correct! It has nothing to do with your situation. I only mention this as a point for the searchers to learn from. Did you try ignoring IPv6? Does it help?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  5. #5
    Join Date
    Jun 2009
    Beans
    32

    Re: wl module has to be restarted after boot for wirless to work

    Aha, so, the ipv6 results are again strange but maybe we are closer now:
    I set it to ignore ipv6 settings for my wireless network as in the picture you attached. I restarted the laptop and it couldn't see my network anymore. So i went and changed back to automatic the ipv6 setting and as soon as i saved it, the network appeared and it connected automatically. The wifi connection is now fine without having to do the rmmod and modprobe for wl!! What do you make of this?
    Last edited by psifunk; January 22nd, 2013 at 04:50 PM. Reason: typo

  6. #6
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,906
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: wl module has to be restarted after boot for wirless to work

    I'm not at all sure what to make of it! I suspect it's an anomaly and that a few days from now, the old behavior may return.

    What, if anything, currently resides here?
    Code:
    cat /etc/rc.local
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  7. #7
    Join Date
    Jun 2009
    Beans
    32

    Re: wl module has to be restarted after boot for wirless to work

    The problem seems to be solved! I changed again the ipv6 to ignore for my wireless network and restarted. This time it saw the network and connected automatically, internet access works, is fast and fine! I restarted a second time and everything seems fine now! So thank you chili555, it seems that I was looking on all other kinds of sources of problems but you did a good diagnosis. Do you have any idea what the issue had been all along with ipv6?

  8. #8
    Join Date
    Jun 2009
    Beans
    32

    Re: wl module has to be restarted after boot for wirless to work

    I suspect it's an anomaly and that a few days from now, the old behavior may return.
    maybe I should torture this a bit more before putting the SOLVED tag

    nothing there
    Code:
    marios@mrLap:~$ cat /etc/rc.local
    #!/bin/sh -e
    #
    # rc.local
    #
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will "exit 0" on success or any other
    # value on error.
    #
    # In order to enable or disable this script just change the execution
    # bits.
    #
    # By default this script does nothing.
    exit 0
    i am restarting again to see if the fix holds

  9. #9
    Join Date
    Jun 2009
    Beans
    32

    Re: wl module has to be restarted after boot for wirless to work

    well restarted again and it works fine. Since I spent several hours with no definitive result, let me make a note for other users that are trying to make the rmmod wl, modprobe wl temporary fix permanent (as mentioned in several threads for slow wifi connection) that it might suffice to ignore ipv6 for the network and forget about these commands.
    Last edited by psifunk; January 22nd, 2013 at 05:11 PM.

  10. #10
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,906
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: wl module has to be restarted after boot for wirless to work

    Do you have any idea what the issue had been all along with ipv6?
    All I know is that some drivers do quite well with the relatively new IPv6 and some not at all well. When I saw that you had a valid IPv6 address from your service provider, I felt that was a likely candidate:
    eth2 Link encap:Ethernet HWaddr 90:4c:e5:77:a8:90
    inet adr:192.168.1.49 Bcast:192.168.1.255 Masque:255.255.255.0
    adr inet6: 2a01:e34:edf9:1990:a4c0:ddea:66c1:53b7/64 Scope:Global
    adr inet6: 2a01:e34:edf9:1990:924c:e5ff:fe77:a890/64 Scope:Global
    adr inet6: fe80::924c:e5ff:fe77:a890/64 Scope:Lien
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    Packets reçus:263 erreurs:0 :0 overruns:0 frame:1842
    Frankly, when you said above that it didn't seem to help, I was skeptical.

    I suggest you watch this for a few days and either mark it Solved or post back and we'll dig deeper.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •